Support » Plugin: Mammoth .docx converter » Inserting spaces at beginning of paragraphs

  • I’ve been using Mammoth .docx converter for a long time with no problems. Suddenly, it’s indenting the first line of each paragraph by 3 spaces. I’m running WordPress 5.6.1 and Mammoth .docx converter 1.17.0.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Michael Williamson

    (@michaelwilliamson)

    Do you get the issue with all documents? Could you provide an example document?

    Is the indentation caused by the CSS on your site, or is it actually inserting three space characters? If the latter, then presumably it’s three non breaking space characters?

    I’m not sure there’s any recent changes to Mammoth that would have caused this. Are you running any other plugins or custom themes? Do you have the same issue when they’re disabled?

    Thread Starter Peter Ditzel

    (@wordo3)

    I’m getting the issue with all documents I’m bringing in from Word and inserted with Mammoth docx.

    Since my site CSS hasn’t changed, I don’t see how that can be the issue. It is inserting 3 space characters. I have to manually take them out before publishing.

    I played around with it and found this: The spaces are inserted only when I convert the text to blocks. This might seem to have nothing to do with Mammoth docx, but it happens only to text that has been inserted by the plugin. Oddly enough, even if I first insert into editor with the plugin and then manually type in a paragraph at the end, and then convert to blocks, the 3 spaces aren’t inserted anywhere. It only happens when all of the text in the post has been inserted with the plugin. Of course, this gives me an easy workaround. All I have to do is type a short dummy paragraph at the end of the Mammoth inserted text before converting to blocks. This prevents any of the text from getting the extra spaces. But it is strange!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.