WordPress.org

Support

Support » Themes and Templates » Spasalon » [Resolved] Inserting pictures in posts

[Resolved] Inserting pictures in posts

  • Hey guys

    First of all congrats on great looking theme.

    Unfortunately I have one big problem. I can’t post pics in posts. I can upload it but when I click on “inser into post” button nothing happens. How can I fix this?

    Thanks foe answer.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Theme Author webriti

    @priyanshumittal

    Hi tonko

    Thanks for appreciating our effort
    Are you facing problem while uploading through feature image or the image through add media just above the editor..

    Hi, nice job it’s a very nice theme
    i have the same problem, when i click on the button inset into post, nothing happens,
    Media are uploaded but i can’t inser into post or page.
    Can you help me ?
    tanks

    Theme Author webriti

    @priyanshumittal

    Hi leobibard

    Things are working fine here…

    Have you tried by deactivating any plugins you are using

    I don’t have any plugin, i re-install the theme but i can’t insert image on post again

    Theme Author webriti

    @priyanshumittal

    @leobibard

    Can you please share your url so that i can assisst you better… if possible allow me to access your admin

    If yes please mail your username and password on my mail id “themes@webriti.com”

    @priyanshu.mittal
    I have exactly the same problem than leobibard.
    I have turned off all plugins and there is no change. I have no problem with uploading logo on background in option panel.

    Theme Author webriti

    @priyanshumittal

    @tonko81

    Which WordPress version are you using..

    I work locally, I downloaded the latest version of wordpress, then installed the theme that’s all. And when you want to put a picture it does not work out.

    My WP version is 3.7.1 and theme version is 1.2.2. When I have used 3.7. it also didn’t work.

    Theme Author webriti

    @priyanshumittal

    Hey thanks mates for reminding this bug…

    We found the bug it is a problem of jquery conflict ….

    Going to make changes in the next release…

    Meanwhile what you can do is

    Comment the scripts my-upload and spa-optionpanal-jquery in function.php and repace the whole code in option_pannel.php with the following code

    <?php
    add_action('admin_menu', 'spa_admin_menu_pannel');  
    
    function spa_admin_menu_pannel() {
    
    	wp_enqueue_script( 'dashboard');
    	wp_enqueue_script( 'wpb_option_pannel', get_template_directory_uri() . '/option_pannel/js/spa_option_pannel.js');
    
    	wp_enqueue_style( 'wpb_option_pannel', get_template_directory_uri() . '/option_pannel/css/spa_option_pannel.css' );
    
    	// color 
    
    	wp_enqueue_style('thickbox');
    	wp_enqueue_style('farbtasticss',get_bloginfo('template_directory').'/option_pannel/css/farbtasticss.css');
    	$page=add_theme_page( 'spa', 'Option Panel', 'edit_theme_options', 'spa', 'spasalon_spa_option_panal_function' );
    	wp_enqueue_style('spa-bootstrap',get_bloginfo('template_directory').'/option_pannel/css/assets/css/spa-bootstrap.css');
    
    	add_action('admin_print_script-'.$page, 'spa_admin_enqueue_script_option_panel');
    	}
    
    	function spa_admin_enqueue_script_option_panel(){
    	wp_enqueue_script('my-upload',get_bloginfo('template_directory').'/option_pannel/js/media-upload-script.js',array('media-upload','thickbox','jquery'));
    
    }
    
     function spasalon_spa_option_panal_function()
     {
    	require_once ( get_template_directory() . '/option_pannel/css/tooltip_css.php' );
    
    	//require_once('spa_option.php');
    	wp_enqueue_script('spa-optionpanal-jquery',get_template_directory_uri('template_directory').'/option_pannel/js/spa-optionpanal-jquery.js',array('farbtastic'));
    	require_once('spa_options_pannel.php');
     }
    ?>

    Super!
    thank you very much, I really wanted to use this theme, it works very well, and I expect the new version with impatience.
    thank you again

    It’s working 🙂

    Thank you!

    @leobibard , @tonko81

    Hey Guys,

    If you like the theme and the support.. would you mind giving it a 5 Star Rating 🙂

    Thanks.
    Ankit

    But now I can’t load front page pics in option panel.

    Theme Author webriti

    @priyanshumittal

    Are your option panel tabs working….

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Inserting pictures in posts’ is closed to new replies.
Skip to toolbar