Support » Fixing WordPress » Inserting Media/Image issue

  • When i click on “Insert Media” and I select an image to insert. The image also inserts at the top of the webpage even though i have placed curser lower down the page in the body. Why is this?

    [IMG]http://i68.tinypic.com/vxpxk.jpg[/IMG]

    In the example above you can see the “shares” image at the top of the body but I want it to insert further down the page in a different part of the body. The curser when i insert image is further down the page.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi @kingleviathan! What browser are you using and what version of WordPress are you running?

    You can move the existing image further down by click and dragging it to where you want it.

    Thanks Robert
    I’m using Chrome and using WP version 5.2

    I could drag the cut and paste the imagine down the page but its causing problems when i view the image using a mobile browser like chrome. The image grows outside the page. (while the image at the top of the page is fine size wise).

    I could drag it but i have three problems
    1. Its a long way to drag it down
    2. Its not practical to have to do it every time i insert a new image
    3. I can’t seem to drag the image lower than the bottom of what is visible on the monitor (meaning i have to stop, click to down array to show more webpage and then drag more.

    The image should be inserting where the curser. This seems to be a recent problem i’m having.

    An alternative to drag and drop is to select the image, press Ctrl+X to cut, move your cursor to where you want the image to be, and press Ctrl+V to paste.

    Could you please share a link to the page with the image? That will help me figure out what’s happening on mobile browsers.

    here you go
    It looks fine in Chrome Browser but not on mobile chrome browser

    https://www.compareforexbrokers.com.au/forex-trading/cmc-markets-vs-ig/

    The odd thing is the image at the top of page is fine on both mobile and web, its image size is large (998 x 226). Scroll down a little and you will see the image again – in this example i’ve changed the image size to 586 x 156 (which is more similar to the image directly above it but it seems to be affecting the look in chrome mobile.

    So it is looking like the issue is when you change the image size? why?

    Note: earlier when i posted for help -it was expanding outside the page without me changing the image size. That doesnt seem to be an issue now (go figure).

    so really i have 2 issues
    1. why is the image being inserted into top of page when i insert media
    2. why is the image not fitting into the mobile webpage

    1. why is the image being inserted into top of page when i insert media

    When I use Chrome, install the Classic Editor plugin, open a long post, place my cursor halfway down the page, and click Add Media, the inserted image appears where my cursor was.

    Do you have any plugins installed that may be affecting this behaviour? You could try temporarily disabling all plugins and seeing if that fixes this issue.

    2. why is the image not fitting into the mobile webpage

    The issue appears to be that the image has a fixed width of 586px which is wider than the width of the mobile version of your page which is 317px. Does not setting a width on the image fix the issue? If not, some custom CSS might fix this:

    .fx-ftu-content img {
    	max-width: 100%;
    }

    Thanks Robert.
    I will need to investigate the insert issue more.

    I see you are right in that 586x x 156h exceeds to page wdith length because when i change the width to 320 it fit in the page perfectly BUT that raises another doubt.

    If you look at that image direct above the image that was exceeding the page (CFD Shares). The dimensions are Full Size – 586w x 121h and it works perfectly fine on mobile. The only difference seems to be this one is “full size” while the one that was giving me problem i made it 586 with custom. Why is it different?

    • This reply was modified 6 months, 3 weeks ago by kingleviathan.

    I found a workaround. SO it seems if i set the size width via the snapshot image capture program it is fine (even if the size is above 320, i’m using 700). The issue is if i customise the width above 320 in wordpress itself.

    Still not sure why its inserting image at top. Maybe it won’t happen on future pages. I can let you know if your interested?

    Glad you found a way around the size problem!

    Still not sure why its inserting image at top. Maybe it won’t happen on future pages. I can let you know if your interested?

    Yes please do, it would be helpful for WordPress developers to know what’s causing your issue with media insertion.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Inserting Media/Image issue’ is closed to new replies.