Support » Fixing WordPress » Inserting Images: "Link URL" won't default to NONE

  • Resolved beggers

    (@beggers)


    I’m using Genesis and a StudioPress Magazine child theme.

    I don’t want a “Link URL” associated with any of my images, but no matter what I do the insertion form always adds the image link. In earlier versions of WP, I just had to select None once and that would remain the default.

    I believe this is a bug but right now I’d like to know how to make it default to None even if I have to hack the code. Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator cubecolour

    (@numeeja)

    You can to go into the ‘secret’ WordPress options admin page at
    http://yoursiteurl.com/wp-admin/options.php
    to change the default setting.

    Look for image_default_link_type. The value will show as file

    The options that can go here are

    • file
    • post
    • none

    Change it to none hit “save changes”

    You can also change this setting by adding

    update_option('image_default_link_type','none');

    To your theme’s functions.php (or custom functionality plugin if you have one)

    Thanks, that solved the problem! I really appreciate it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Inserting Images: "Link URL" won't default to NONE’ is closed to new replies.