Support » Plugin: Better Font Awesome » Inserting empty Tags when picking icons in wordpress visual editor

  • Resolved nrmn

    (@nrmn)


    Hey,

    when i pick an icon in the wordpress visual editor, the insertet shortcode allways looks like this:

    [icon name=”” class=”” unprefixed_class=””]

    It is allways empty. No icon name is filled in, regardless which icon i pick.

    I can then write the name manually and it will also appear in the frontend, but the whole function of the icon picker is useless.

    I have the latest version of the plugin.

    This behavior also occurs, when i activate the option, to remove existing font awesome.

    Also some icons are not displayed within the icon picker. There are some white boxes between the other icons.

    I found nothing similar in the forum or the web and would be very happy, if you could help me with that =)

    Thanks in advance,

    Norman

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mickey Kay

    (@mcguive7)

    Hi Norman,

    Sorry to hear you’ve run into this issue. I’ve never come across it before, so I’m inclined to believe it may be do to some theme/plugin conflict on your end. I hate to suggest the typical “have you tried disabling other plugins?” route, but I think that’s worth a shot in this case.

    Can you tell me, do you see any warnings in the admin? If BFA runs into issues fetching fonts, it will do its best to display a useful notice in the admin.

    Hey Mickes,

    i investigated this further.

    It seems, that the Optimizely classic plugin causes this behavior. When i deactivate it, the icon picker works again (but still some icons are not displayed in the icon picker).

    i also found, that the same error occurs with shortcodes ultimate. They have a icon picker too, for example to choose a list style icon. When Optimizely is active, this icon picker shows the exact same behavior: icons are displayed, but when chosen, the icon name stays empty. When i deactivate optimizely, the picking works fine.

    I have already submitted this to the Optimizely support. Do you habe an idea, where the interferring could happen?

    Thanks for your help,

    Norman

    Plugin Author Mickey Kay

    (@mcguive7)

    Hey Norman,

    Without checking out your site, it’s hard to be sure, but my first guess would be a JS conflict of some kind, or perhaps a conflict in versions between two copies of the same asset (e.g. the other plugins loading a different version of the popover JS).

    Thanks for the hint =)

    I hope the Optimizely-Team will respond to my request -_- I did not hear from them yet…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Inserting empty Tags when picking icons in wordpress visual editor’ is closed to new replies.