Support » Fixing WordPress » Insert/Edit Link not working – deletes post i'm working on

  • Resolved reneewalton


    Just this morning I went to create links to other sites/videos as I’ve always done. When I hilite the word I want to be a hyperlink, I click on the link icon in toolbar (as always) and then enter the URL it should take users to. When I hit update, now a pop up box opens up asking if I want to Leave the Page or Stay. If I choose Stay, it goes back to draft post with no link. If I choose Leave, it erases my draft post and gives me a new blank one. either way, I’m unable to insert any links. I’ve tried refreshing to no avail. Any solutions here?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have a similar problem, but I can’t highlight or edit my draft post at all! Also, when I click on the icons in toolbar (link, or boldface, or block quote, or any of the icons), nothing happens. I was able to insert a link when I switched to html mode – but then it didn’t offer me the usual option to “open in new window.”

    This always worked in the past. And I can still edit my OLD posts normally. But this problem comes up with new posts. It started last night (July 7).

    I think there’s a problem with the wordpress site. How to fix?

    tcshaffer: I’m going to take a shower, take a drink and take in a movie. Hopefully WP will be fixed by the time I get back! At least we’re not alone (small comfort, i know) SOS going out to those WP EXPERTS!

    Okay, tcshaffer – I have solved my problem and hopefully this will solve yours too. It was a plugin that was messing me up – for me it was the WordPress SEO by Yoast plugin. Here’s what I did to find out which one it was (i have about 20 plugins in all).

    I first noted which ones were “Active” right now. Then I deactivated all of them. Then I went back to my draft post and hilited a word, clicked on the link icon, inserted the url into the pop up box and voila! It linked and worked! Then I went back to Plugins and activated the first one, switched back to Posts & highlited a word, hit the link icon, inserted url and it worked. So i went back down to Plugins and activated the 2nd plugin, then back up to Posts and tried it out again – it worked. And so on, activating each plugin and then retesting in Posts until they were all done except the last one.

    It was the last one that when I turned it on, then tried the link, it didn’t work. That one for me was WordPress SEO by Yoast. To be fair the plugin site does say it’s in Beta with no guarantees to work. Good luck! (and PS – don’t go see Bad Teacher)

    Reneewalton – I tried your solution and it didn’t work for me. I only had 3 plugins, and none of them was experimental; deactivating them made no difference. The a friend suggested that I use the Firefox browser to access the WordPress site (instead of Internet Explorer). Bingo. It worked normally. I have no clue what the problem was in Internet Explorer, but at least I have a workaround to make my WordPress site work!

    If anyone has a clue about what the problem was with Internet Explorer, I’m interested, because I’d prefer not to have to remake all my browser arrangements!

    I used to use IE all the time, for years. In the past 6 months I started experiencing a lot of problems when I wanted to do stuff on the internet, in particular watch video clips on websites (in particular, some Dr. Oz segments that friends would send me). These were things I’d been able to watch before with no problems. I also noticed that I couldn’t see some online ads – they were blacked out. I asked around, no solutions. Then I took my computer to the Geek Squad at Best Buy and the guy told me to NOT use IE. He said it was in Beta-testing (huh? it’s been around forever?) and that lots of people have problems with it. He suggested that i use Firefox or one of the others – the minute I switched to Firefox I could watch any video, anywhere, and see all the ads. It was instantaneous. I suggest you dump IE and try Firefox or Google Chrome, and see how they treat you. Good luck!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Insert/Edit Link not working – deletes post i'm working on’ is closed to new replies.