Support » Fixing WordPress » “Insert/edit link” Feature In Editor Not Working properly in Chrome

  • Since my site updated to 4.7.4 the Insert Link isn’t working properly while using Chrome.

    I usually do the following:

    Write my text, highlight it and click Add Link (or CTRL+K)
    In the window that pops up, add the link URL

    So if I press the ENTER button at this point it all works.

    However, I want my links to open in new tabs/windows so I press the Settings Cog icon on the right.
    At this point, Chrome de-selects the text and when I accept the changes, nothing is added or changed from default text.

    What it should be doing here, of course, is making the highlighted text into a link with the target=”_blank” attribute.

    I tried the same flow in Edge and it works fine. So not sure what in 4.7.4 changed enough to get on the bad side of Chrome 🙁

    I notice a similar issue was mentioned on an earlier version of WordPress but there didn’t appear to be a solution in that thread.

Viewing 8 replies - 31 through 38 (of 38 total)
  • Same here. please fix it 🙂

    Hi there,
    It’s fixed in WordPress 4.8 version.

    If you cannot update WordPress version.

    Then here is the solution:
    http://www.miraclewebsoft.com/insert-edit-link-feature-editor-not-working-properly-chrome/

    It’s working in all browsers

    Oh, thanks. i guess i was to quick reading, i have a greater problem, i can’t even press on the floating toolbar buttons and i am using 4.8.

    A few weeks ago I’ve wrote: “Hi I’ve a customer with the same problem. I’ve updated the website to wordpress 4.8 but she still can’t add links with the visual editor. It works only if I don’t select a word but obviously it add a link on nothing. In the console I can see this error:

    Uncaught TypeError: Failed to execute ‘setStart’ on ‘Range’: parameter 1 is not of type ‘Node’”.

    So I guess there are still issues also on the 4.8 version.

    alex.gav

    (@alexgav)

    Is there any solutions for MCE floating toolbar while site is in RTL language?

    I’m on WP 4.9.4 and having the same problem. Create the link in the edit mode for the post then publish, then go to the website and the text does not contain a link. This happens no matter whether I create the post while I’m on Opera, Chrome, or Fire Fox. However, if I enter the link on a page then go to the website the link works. So it seems limited to creating or publishing a post and not to the browser

    @warehouseman, you might want to check your version of WP. The latest stable version is 4.9.1 This particular issue was fixed back in 4.8.x (I can’t recall exactly which update release it was.)

    Hi,

    Many of my clients are having same issue on different hosting providers /using different themes and plugins. tried everything but still not working

Viewing 8 replies - 31 through 38 (of 38 total)
  • The topic ‘“Insert/edit link” Feature In Editor Not Working properly in Chrome’ is closed to new replies.