Support » Fixing WordPress » “Insert/edit link” Feature In Editor Not Working properly in Chrome

  • Since my site updated to 4.7.4 the Insert Link isn’t working properly while using Chrome.

    I usually do the following:

    Write my text, highlight it and click Add Link (or CTRL+K)
    In the window that pops up, add the link URL

    So if I press the ENTER button at this point it all works.

    However, I want my links to open in new tabs/windows so I press the Settings Cog icon on the right.
    At this point, Chrome de-selects the text and when I accept the changes, nothing is added or changed from default text.

    What it should be doing here, of course, is making the highlighted text into a link with the target=”_blank” attribute.

    I tried the same flow in Edge and it works fine. So not sure what in 4.7.4 changed enough to get on the bad side of Chrome šŸ™

    I notice a similar issue was mentioned on an earlier version of WordPress but there didn’t appear to be a solution in that thread.

Viewing 15 replies - 1 through 15 (of 38 total)
  • Damon Cook

    (@colorful-tones)

    Hi Bazajaytee,

    I’m trying to narrow down the steps to recreate the issue. If I’m understanding you correctly the issue lies somewhere in when editing an existing link in a post.

    So steps to recreate issue are:
    1) Click cursor on an existing link in the TinyMCE editor.
    2) Click the pencil “Edit” icon and the inline link editor field is shown
    3) Click the cog icon for “Link Options”
    4) Check the “Open link in a new tab”, and hit Enter / or click “Update” button.

    Are you typically in the Visual or Text view of the editor when encountering this issue? Please see screenshot here if you’re not sure what I mean: https://make.wordpress.org/support/user-manual/content/editors/visual-editor/

    I just tried on base install of WP 4.7.4 in Chrome 57.0.2987.133 (64-bit) and not noticing any odd behavior. Again, I may be missing the issue though.

    I notice a similar issue was mentioned on an earlier version of WordPress but there didnā€™t appear to be a solution in that thread.

    If you happen to have a link to that issue it could be helpful.

    Thanks.

    Damon Cook

    (@colorful-tones)

    Also, three things I can think of you might want to try:

    1. When you encounter the issue in Chrome can you open the Developer Tools and navigate to the Console and see if there are any errors (usually in red). There may be some JavaScript (from plugin or theme) interfering here.
    2. Try temporarily Deactivating all your Plugins, and then see if the issue persists.
    3. Last, try switching to another Theme temporarily and see if the issue persists.
    • This reply was modified 2 years, 7 months ago by Damon Cook.

    This isn’t editing a pre-existing link but adding a new one to existing text. I use the Visual Editor mainly except for when embedding Twitter posts which Visual mode scrambles up if I switch between Text and Visual. That is another issue though.

    So in the editor type any word, like HELLO
    Highlight it and click the Add Link (you’ll see the word is still highlighted in the background as the overlay shows up)
    Click the Link Options icon (the cog)
    The text will not be highlighted anymore and anything you do won’t create a link.

    I do see an error in Chrome pasted below:

    JQMIGRATE: Migrate is installed, version 1.4.1
    public-api.wordpress.com/:482 WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403
    pinghubAdd @ public-api.wordpress.com/:482
    2(index):482 WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403
    pinghubAdd @ (index):482
    pinghubConnect @ (index):451
    handlePinghubMessage @ (index):433
    receiveMessage @ (index):171
    (anonymous) @ (index):250
    dispatch @ s0.wp.com/:3
    r.handle @ s0.wp.com/:3

    This was the old thread on a prior version of WordPress btw. https://wordpress.org/support/topic/insertedit-link-feature-in-editor-not-working/

    Hey, I’m facing the same issue but that was creating by a plugin name Ultimate Nofollow. I uninstalled that plugin and Insert/edit link function working fine. Maybe you have a different issue but if you are using that plugin or similar plugin then try it by deactivating it.

    Same issue here. Creating a new link won’t work if the box is checked off to open external.

    Chrome is showing this error:

    wp-tinymce.php:7 Uncaught TypeError: Failed to execute 'setStart' on 'Range': parameter 1 is not of type 'Node'.
        at c.select (wp-tinymce.php:7)
        at Object.mceUpdate (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,suggest,wp-ajax-responsā€¦:691)
        at Object.update (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,suggest,wp-ajax-responsā€¦:691)
        at HTMLInputElement.<anonymous> (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,suggest,wp-ajax-responsā€¦:691)
        at HTMLInputElement.dispatch (load-scripts.php:3)
        at HTMLInputElement.r.handle (load-scripts.php:3)

    Hey Guys,

    I’m experiencing the exact same problem. When I copy a text and try and link it to a URL, after making the open in new tab and URL change, it randomly places the same text with a link and highlight right next to the previous text that I selected. It’s damn strange and this has never happened before. Could this be because of any update?

    How can I resolve it?

    Thanks

    Shyam

    I only started seeing it when my site updated to 4.7.4.
    Previous to that, no problems at all.

    According to the change list, there were a lot of TinyMCE changes. Any one of those could have brought in what we are seeing šŸ™

    https://core.trac.wordpress.org/log/branches/4.7?rev=40487&stop_rev=40224

    Same problem here – driving one of my colleagues to despair.

    Only seems to be on sites that upgraded to 4.7.4 and him using the Chrome browser, which unfortunately is our preferred setup..

    I have the same problem. Using Insert/edit link does not work any more. Usually in the Visual editor it adds the underline to the text but not even that.

    Only workaround is to copy the URL link, then paste the link text over the words you want to use as the “link text”.

    No new plugins installed. Only since the last WP upgrade.

    Yes, major problem. I’m using FireFox and experience the same scenario. I can manually apply the link in Text mode, but that doesn’t help all my customers.

    And another one with the same problem – cannot insert link in visual mode.

    I’m experiencing the same thing. No new changes. I’m working in Chrome.

    Adding myself to this list. Cannot get links to create using the visual editor. Running WordPress 4.7.4 on Chrome 58.0.3029.81. No recent changes to site setup other than the WordPress version change. Deactivated all of my plugins to see if that made a difference, and it still isn’t working properly. Have to go in and manually add the tags. Not a fun time.

    • This reply was modified 2 years, 6 months ago by SchuminWeb.

    I’m so glad I found this thread, because I thought I was going crazy. I’m experiencing the exact same issue, but it’s not restricted to WordPress.org sites. I have one site that I’m webmaster for that is a WordPress.com site and was forced to manually code all the links. Thankfully, I know how to do that.

    I have check the system using Edge (as much as I hate using that particular browser) and it was fine. This is definitely a Chrome-only issue, but relates to ALL of WordPress.

    @judylmohr just to reiterate, I have experienced the same problems on FireFox. Hopefully a fix will be rolled out soon.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘“Insert/edit link” Feature In Editor Not Working properly in Chrome’ is closed to new replies.