[resolved] Insert/edit link box NOT WORKING. (6 posts)

  1. rubian77
    Posted 5 years ago #

    I just upgraded to 3.2.1 this morning...and am not happy.

    I wanted to add a link to some text. So I did the usual highlight text, click the add/edit link box in the toolbar, and got the pop-up box...but after entering the link and clicking "Update" I get a notification that says "The changes you made will be lost if you navigate away from this page." If I click "Stay on this page," no amount of clicking "Update" will actually update the link... and clicking "Cancel" on the add/edit dialog box does NOTHING (I have to click the X). Clicking on "Leave this page" closes the dialog without saving changes and sends me to a page totally different than the one I was trying to add the link to. Also, the "Or link to existing content" option doesn't do anything even though I get a hand-cursor when I mouse over it.

    I am getting the same problem in IE 7, FF 5, and Chrome. Why is it doing this, and how do I fix it?? Thanks in advance!!

  2. Sabinou
    Posted 5 years ago #

    I'll let the pros handle the pro reply, however have you tried the "reinstall wordpress automatically" from your dashboard ?

    Nothing will be lost if you try that, and perhaps a broken installation, whatever the reason, could be the cause...

  3. esmi
    Forum Moderator
    Posted 5 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  4. rubian77
    Posted 5 years ago #

    I noticed that most (if not all) of my plugins needed to be updated, so I tried to update them (thinking that might be the issue) -- half of them had errors and completely removed the entire plugin (great), and the other half I deactivated because I don't really need them.

    The link-adding is working again. :)

    Now to just get my necessary plugins back...

  5. NZWineDirectory
    Posted 4 years ago #

    Hi all

    Had the Same Problem - WordPress SEO Version 1.0.1 | By Joost de Valk was the plugin that affected it. Works fine again now

    Cheers JB

  6. all41inc
    Posted 4 years ago #

    I'm having the same problem on my site. I'm using 3.2 and the "link" button stopped working about three days ago, and I've been pulling my hair out ever since.

    If I disable all my plugins, will it affect my website. Will all of my ads disappear, and so on. Or can I disable them all (keeping website intact), only to later reinstall the ones I need?

    It's very annoying! So much so that I've been looking at other programs to build my next site. I don't want to, though... WordPress is very user-friendly (when it works), especially for non-programmers like myself.

Topic Closed

This topic has been closed to new replies.

About this Topic