Support » Plugin: Ultimate TinyMCE » Insert/Edit Image not working

  • Resolved websupportguy


    I have been using Ultimate TinyMCE for a while now, but can’t seem to resolve a problem with inserting inline images. When I click the image icon I get a dialogue box full of placeholder codes like {#advimage_dlg.tab_general} and so on.

    Someone elsewhere talked about perhaps the language file does not load. But not sure where to look for that. I’ve tried deleting the plugin entirely and reinstalling it but have exactly the same problem.

    Can anyone help?

    JOSH: Can’t post on your forum as it refuses to send me the confirmation email (username:websupportguy).

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Josh


    Moderator and Editor Customizer

    Hi there,

    My forum has been acting a little odd lately. If you don’t mind.. wait about an hour and try again. If still unsuccessful, please post back here and I’ll manually create an account for you.

    Although your issue does seem language file related… I doubt this is the underlying issue.

    Let’s first try Manually clearing your browser cache. Also, empty any caching plugin you might be using.

    Refresh everything… and try again.

    Hi Josh, still no email verification from your forum. I don’t currently use any cache plugin on this site. Posts on Joomla forum suggest it may not be loading the EN language file from the plugin folder. Where is this loaded in the script? I can try some debugging. May be a strange path issue. The Joomla people found a solution to this problem but I can’t translate that to a WordPress fix.

    Plugin Author Josh


    Moderator and Editor Customizer


    Okay, I’ve manually activated your account on the ultimate tinymce forums… so you should be good to go there.

    If you have trouble loggin in… let me know and I’ll tell you how to contact me personally so I can send you the info securely.

    The language file for that addon will be located in the “ultimate-tinymce/addons/advimage/langs” directory. There is only one file there.

    NOTE: I’m thinking this might be a server permissions issue. You may want to check your folders in that directory to make sure they have the correct permissions set.

    Does this only happen when you use that one button?

    Yes, only on the image function. I have currently uninstalled the plugin and installed Advanced TinyMCE on my production site, which has a similar image function and dialogue box. It works fine. But I don’t consider it in the same league as your plugin, so I’d prefer to get that working. I am still running your plugin on my test site. I could give you access to that if you want to take a look at the problem.

    I am not a JS coder, but in reading advimage/js/image.js it looks to me like the popup may be requiring the DOM language setting. Is this correct? What would happen if the language was not set in the DOM? I know I have an issue with this WP theme not correctly setting the site language as Google highlights it in Webmaster Tools. No idea yet how to fix it. Is it possible this is an issue?

    I’d like to see the file which actually reads the language file to see if it’s pointing to the right place. I cleared my browser cache and checked the file and folder permissions. Could not find anything unusual there.

    Sorry, I tell a lie! The Youtube insert function and the edit CSS function are doing the same thing. I had not used that before. But embedded media is OK.

    I just tried switching themes back to Twenty Eleven on the test site to see if that fixed the problem, but it didn’t. So that probably rules out being a theme-related issue.

    Plugin Author Josh


    Moderator and Editor Customizer

    Okay… Please use my contact form to send me the admin login details for your test site.

    Here is a link to my contact form:

    Please include a link to this thread, the login url, and the username and password.

    We’ll figure out what’s going on!!

    Plugin Author Josh


    Moderator and Editor Customizer

    I think we resolved this via email. I am going to mark this thread as resolved, but please let me know if there is still an issue. Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Insert/Edit Image not working’ is closed to new replies.