WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » Insert Media: Yoast SEO Meta Info Won't Save

Insert Media: Yoast SEO Meta Info Won't Save

  • For some reason when I’m adding an image via the media uploader, I put the WordPress SEO meta information in the box below the image (just like in a post), but when I hit the update button, the SEO info will just disappear.

    I’m not sure what’s causing this issue. When it was brought up that with WP 3.5 Image titles are disappearing after inserting into post, the moderator on the WP forum stated this:

    This was an intentional change made in the name of accessibility.

    Which made no sense since Google still likes images to have a title when you’re doing Google News.

    Hopefully this is just an easy fix. Right now I’m having to go in and add the image title again after posting. I was hoping that since the WordPress SEO Metabox was showing up with the images, this would be a great workaround.

    Any help would be greatly appreciated.

    Curt

    http://wordpress.org/extend/plugins/wordpress-seo/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Just ran into the WP3.5 image insertion issue myself. Deactivating Yoast SEO solved the problem. Just figured I’d mention it. I *just* switched themes after the one I bought over the summer didn’t work with Yoast active.

    Looking forward to an update.

    I updated to WP3.5 and I’m having same issue with my media. I enter SEO info on image page, click update and entries are removed.

    One thing that sucks with the new WP 3.5 update is that when you put in a Image Title (or it’s pulled from the image file name) it’s stripped out after you insert into a post.

    WP had this to say about it.

    I’m sorry (but not actually sorry) that the tooltip community has felt slighted by this one, but we won’t need to make a change. We made a choice, and this choice on the whole benefits all users and readers, not just those using screenreaders. How often have you moused over an image on a WordPress site and saw “IMG_1234”? One of the lamest things ever. Never again.

    Tooltips can still be added by opening the Edit Image modal and inserting something into the title attribute box. The only change is that the “Title” field — which is the name of an image’s attachment page — does not populate the title attribute.

    What really sucks is that for those of us on Google News, you have to have the Image Title included or your image won’t go with your article. I found it odd that WP mods seemed to think it unreasonable to want to keep an Image Title, but hopefully whatever issue bug is keeping WordPress SEO from securing the Meta information we add on images will get fixed. At least this will properly have our images SEO’d.

    Same issue with trying to save a SEO Title, Keyword, Meta Description.

    WordPress version:3.5
    WordPress SEO version: 1.3.3

    I did this: Changes the SEO Title, Keyword, Meta Description.

    I expected the plugin to do this: Change the SEO Title, Keyword, Meta Description for a page.

    Instead it did this:Defaulted back to what it was before I tried to make the change.

    I want to add that it only happens to some pages, but not all.

    http://wordpress.org/extend/plugins/wordpress-seo/changelog/

    “1.4.5

    Bug fixes:

    Allow saving of SEO metadata for attachments.

    SEO data wont save for selected static pages either…..

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Insert Media: Yoast SEO Meta Info Won't Save’ is closed to new replies.
Skip to toolbar