WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Insert Links not working in 3.5

[Resolved] Insert Links not working in 3.5

  • This seems like a pretty obvious bug, and I’m surprised it wasn’t fixed instantly.

    When you go to insert a hyperlink in the body of a post the link window will pop up at the far lower left of the screen. Then once you input the information the window will not close and save the changes.

    Considering most posts have a number of hyperlinks that mus be added this is a HUGE bug.

    I have tried this in Mozilla, Chrome and IE and it does the same in all of them.

    Now I have to figure out how to successfully regress to 3.4 without messing up my site. no happy, Not impressed. I expected more from WP at this stage of the game.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Chris Olbekson
    Level 12 Bug Squasher & Forum Moderator

    @c3mdigital

    I can not reproduce your problem. The popup is in the middle of the post editor and closes instantly when the add link button is clicked.

    Possible javascript conflict with theme or plugin:
    Please disable or delete all plugins and switch to the default theme (TwentyEleven since 3.3). After making these changes does the problem still occur? If no, re-enable everything one by one to see which component causes the problem.

    You’re joking? Wonderful. I certainly have time for that. How do I go back to 3.4? That would be MUCH easier.

    Well I got it working. Thanks. now I’ll need to go through all 30 plug ins and find the issue.

    I updated to 3.5 and I have the same issue. Links do not work in text or visual editor.

    Just an FYI, but my Jetpack stats also disappeared when I updated to 3.5, and won’t return even after reconnecting to WordPress/Jetpack – different issue though.

    In my case it turned out to be a Slider plug in. Fortunately I no longer needed it because of the one that is included in Jetpack.

    help gentlemen.
    I have the same problem.
    when I insert the link will become demagnetized.

    dbhinckley
    Member

    @dbhinckley

    Same problem here.

    • Deactivated all plugins
    • changed to 2012 theme

    with no change.

    I am not keen to try to figure out how to go back to 3.4.x

    Any other suggestions from anyone?

    Self-installed at Bluehost

    digitalhigh
    Member

    @digitalhigh

    Hello I have the same problem with the insert link
    it doesnt work correctly
    it bring a pop up window transparent without anything

    i have also a problem where the post text is not respecting the position at all ,
    anybody could help?
    thanks

    dbhinckley
    Member

    @dbhinckley

    The mystery deepens for me:

    – on my 3.4.2 install, the insert links are broken as well
    – when I connect to that same install from my iPad WP app, I can create links which work (so it doesn’t seem to be an issue on my server).
    – The problem seems to be independent of browsers used.
    – Problem is independent of platform: happens on Windows XP or Mac OSX

    I’m running Mac OSX Snow Leopard on my desktop machine.

    sfloyd1970
    Member

    @sfloyd1970

    I am having the same problem…

    When I changed themes to default, it worked…

    But plugins made no difference…

    Guess I am screwed unless my theme maker updates???

    esmi
    Forum Moderator

    @esmi

    As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem – despite any similarity in symptoms – is likely to be completely different.

    The.MacGuffin
    Member

    @themacguffin

    I have the same problem and am equally amazed there is no solution posted.

    Same problem here and also found that disabling plugins didn’t help. Have latest versions of WordPress and theme installed. As the OP suggests it’s astonishing that this hasn’t been addressed – are we seeing the end of WordPress as a reliable and trusted platform? Am adding links by hand at present but many will drop WordPress is basic problems bugs this are allowed to develop and then are not addressed.

    jj_sailing
    Member

    @jj_sailing

    I have been trying to solve this problem for weeks.
    I’ve tried
    (1) deactivating plugins and clearing cache
    (2) clearing plugins in myphpadmin
    (3) downloading and manually installing 3.5.1
    (4) adding to wp-config.php
    define(‘SCRIPT_DEBUG’, true);and
    define(‘CONCATENATE_SCRIPTS’, false);
    (5)getting support from my theme provider.

    Please new ideas anyone!!!

    Hi I have a similar problem after upgrading to WordPress 3.5.1 I tried to insert a hyperlink and an image in a new post but didn’t work. I did everything that was recommended, and what I found was:

    The problem is with the Feast template, I know this is a commercial template, but I just want you to know that in my case the problem was with the template and not the plugins. If somebody can give me any direction, I appreciate it.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] Insert Links not working in 3.5’ is closed to new replies.