Support » Fixing WordPress » Insert link no longer showing existing content

  • Resolved rjmedina


    Hi everyone,

    Up until two days ago, when I wanted to insert a link to a previous post, all posts showed up in the “or link to existing content” space. As of yesterday nothing shows up here nor does entering anything in the search field bring up anything other than an endlessly spinning circle. It’s as if WordPress can’t see any of my own content.

    I’ve tried the following: disabled all plugins but the issue is still there. I’ve changed the theme to 2012 with disabled plugins but again the issue is still there. I’ve reinstalled WordPress from the Dashboard but still nothing. Any other suggestions? I can still link to my content by copying and pasting but this is a bit more cumbersome than it used to be.

    I did install and then uninstall an app available through Attracta SEO on HostGator that searched for broken links on my website. I’ve since deleted it hoping it might solve the issue but it didn’t.

    I also have a pro version of Wordfence installed and all scans show no issues.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Ok, since I have no response to this question, is it safe to say I’ve been hacked and need to do a fresh install of WordPress on my server?

    So here’s the latest on this bug.

    Working with Hostgator, they too could not resolve the issue on their end after disabling all of my plugins and installing a default theme. They suggested I do a clean install on a subdomain and if that worked migrate over to root after everything was up and running again. I did. Same issue on this subdomain install after I uploaded my content from a WordPress backup.

    Then I decided to do a second clean install on a second new subdomain but not upload any files. Wrote three sham posts and I still couldn’t link to any of them in the insert link popup window or do a search in that same window. Hostgator claims it’s a WordPress bug so that’s all they could offer me.

    As I said, when I try to do a search in my insert link window, the wheel just spins with no results. Checking my web console on Firefox, I get a series of these requests until I hit cancel: / is my website.

    Any ideas why this might be happening? The issue appears to be with Hostgator but I don’t know what they have to do to resolve it.

    Great news! Problem solved!

    Contacted Attracta support today. Even though the “Broken Links” plugin showed that it had been deleted on their site, the hidden file was still in my root directory on Hostgator. After removing it, everything works again! Here is the email from Attracta support should anyone run into this in the future:

    1. Please log into your Attracta account
    2. Navigate to the ‘SEO Apps’ link in the top left menu
    3. Ensure the domain you wish to remove the app from is selected in the ‘Selected Site’ dropdown
    4. On this page, you’ll see a list of installed applications under ‘My Installed Apps’
    5. Click on the ‘Manage App’ button
    6. To remove the app, click on the ‘Uninstall Application’ button near the applications icon at the top of the page.

    NOTE: It may take up to 8 hours for the update to process and the application be disabled.

    If you need the app disabled immediately, you will need to delete the .fastinclude file from the ‘web root’ (document root) of your website.

    To delete this file:

    1. Log into your cPanel account
    2. Navigate to ‘File Manager’
    3. Choose the ‘Web Root (public_html/www)’ option and ensure ‘Show Hidden Files (dotfiles)’ is ticked.
    4. Click Go
    5. Select the public_html folder on the left
    6. Select the file named ‘.fastinclude’ and click Delete

    After deleting this file, the app will be removed instantly. However, this will not communicate with our systems so we recommend that you also do the first 6 steps to keep your account in sync with us.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Insert link no longer showing existing content’ is closed to new replies.