Support » Fixing WordPress » Insert link button doesn't create a link in visual editor

  • I’m doing the following:

    1. Highlight a word
    2. Click the “Insert Link” button in the visual editor
    3. Dialogue comes up, enter link, with or without additional title
    4. Submit
    5. 90% of the time nothing happens, ie the popup dialogue closes but no link is created. Intermittently if I repeat this process 2-5 times the link will be created.

    My website address is: http://www.greenrenovation.com.au/

    Things I’ve tried:
    1. Disabling all plugins (currently so)
    2. Switching to a default theme (no change, since reverted back)
    3. Clearing all cookies from my browser cache
    4. Using a different computer that has never previously been used to edit the site.
    5. Reinstalled version 4.1 via the “Re-install Now” button on the WordPress Updates page within WP-Admin.
    5. Running the JavaScript console. This shows an error (pasted below) which 100% correlates with the insert link function not working. The infrequent cases where the link creation works this error is not reported.

    Uncaught TypeError: Cannot read property ‘nodeType’ of nulltinymce.min.js?ver=4107-20141130:4 walktinymce.min.js?ver=4107-20141130:6 dtinymce.min.js?ver=4107-20141130:6 ytinymce.min.js?ver=4107-20141130:7 C.mceInsertLinktinymce.min.js?ver=4107-20141130:6 vtinymce.min.js?ver=4107-20141130:9 N.execCommandload-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,wp-ajax-response,jquery…:885 wpLink.mceUpdateload-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,wp-ajax-response,jquery…:885 wpLink.updateload-scripts.php?c=0&load[]=hoverIntent,common,admin-bar,heartbeat,autosave,wp-ajax-response,jquery…:885 (anonymous function)load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,plupload,json2&ver=4.1:3 m.event.dispatchload-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,plupload,json2&ver=4.1:3

    I’ve searched google extensively for the symptoms and error message above but haven’t been able to locate an answer.

    Any assistance would be greatly appreciated.

    Regards,

    Andrew Rogers

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Andrew,

    I’m not sure, if you still have the link-problem.

    If so, have you tried installing the following plug-in (published by Andrew Ozz, latest version is 4.1.7):
    http://wordpress.org/extend/plugins/tinymce-advanced/

    This plugin won’t solve the root problem, but allows you to customize the built-in editor in the WP back-end.
    I know of a few folks who had similar problems and installing / using it has helped them.
    See also the following post which I used as a reference: http://wordpress.org/support/topic/cant-insert-links-with-visual-editor#post-1329918

    1. After installation is complete, Activate the plugin.
    2. Go to the dashboard of your admin
    3. On the left hand side, find the TinyMCE Advanced listed under “Settings” and Open it up.
    4. You will see your existing WYSIWYG editor followed by two empty gray rows. Below these two empty rows are a lot of new buttons.
    5. Add buttons by clicking and dragging from the bottom to the two empty gray rows. Even if you do not need to add buttons, add at least one to make sure that the plug-in is initiated.
    6. Save settings.
    7. Go to edit a post or a page and try highlighting and creating a link.
    8. It should work now

    Hope, this helps you 🙂

    Thread Starter andrewrogers

    (@andrewrogers)

    Kunstwerck,

    Thank you so much. This solved my problem and now hopefully others that will find this answer!

    I had been using the TinyMCE Advanced plugin but adding the buttons to the lower two rows seems to have been the fix.

    Greatly appreciated.

    Regards,

    Andrew Rogers

    Hi Andrew – I’m very happy I could help you 🙂

    Could you, please, mark the topic as resolved?

    Many thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Insert link button doesn't create a link in visual editor’ is closed to new replies.