Support » Fixing WordPress » "Insert Into Post" Button missing with 3.2.1 HELP

  • This is about to drive me insane so please please help. I’ve tried searching for the answer and can’t find it.

    So the “Insert image into post” option seems to be completely gone. This isn’t an upgrade it is a brand new wordpress install and it’s not there. I don’t have any plug ins activated, I haven’t even installed any plug ins yet, jetpack isn’t even activated. I have switched back to the Twenty Ten and Twenty Eleven and it still doesn’t work. I’ve updated my firefox and IE and it doesn’t work. I didn’t even manually install I used my godaddy hosting connection which I always use to install my wordpress and it’s never had a problem before. I don’t know what is going on. I hate this new update. Can someone please tell me what’s wrong?

    The only thing I have is the use as featured image and the save options. There is no Insert option. I can do it manually by using HTML but my clients who I set up for don’t know anything about using HTML so I have to get this fixed Pronto.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m having the same problem and still haven’t found a solution. Does anyone know what’s going on?

    I thought I had succesfully installed the Garnish (1.2) theme (by Premium Pixels) on a clients’ website, which uses pages to create portfolios. With two Portfolio skills (Documentary and Photography) that were in working order.

    But now something strange happened. Creating a new portfolio is possible, but the WordPress (3.2.1) picture upload suddenly only shows the <b>Save changes</b> changes button but not the <b>Insert into Post</b> button is visible. I’ve checked the chmod settings (755 changed to 777 does not work either).

    Same thing with normal posts. So it seems a WP thing as well as a possible theme problem.

    You can find the site over here:

    hi there,

    has anybody solved out this problem? i am having the same issue and couldn’t find a solution at all…

    The problem I had was in the theme (in functions.php), and was solved by adding some code to this theme file. Thanks to Gerard van Enk it was solved with this:

    /* 2011-11-16 -
      fix for problem with missing insert-into-post buttons
    add_filter('get_media_item_args', 'force_send_to_post');
    function force_send_to_post($vars) {
        $vars['send'] = true; // 'send' as in "Send to Editor"

    I’m not sure if it will help you guys? But have a look.

    thank you, i’ll reply as soon as i check

    is it the (theme-functions.php) file? where exactly is it added?

    oh got it!

    great! totally worked for me

    wp 3.2.1
    garnish theme

    the file is “functions.php”

    thaks a thousand times =)

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘"Insert Into Post" Button missing with 3.2.1 HELP’ is closed to new replies.