Support » Fixing WordPress » Insert images in WP 2.7 not working

  • Resolved astromono

    (@astromono)


    Hi there, I’m having an issue with the insert image option in WP 2.7. Whenever I upload images to use in a post, I go to Insert Image > Gallery and then the list of images pops up, but nothing happens when I click on the “Show” link.

    Is there something I should update on my end aside from the installation? I did delete the wp-admin and includes folder and then replaced them with the ones in the zip file, so no overwrites.

Viewing 15 replies - 1 through 15 (of 45 total)
  • Moderator Andrew Ozz

    (@azaozz)

    WordPress Dev

    Are there any js errors? What happens if you upload a single image only?

    Thank you for replying! There aren’t any js errors, when I upload a single image it lets me edit it after it finishes uploading, but say I edit it and put it in the post. If I try to go back and edit it again, it won’t let me because nothing happens when I click on “Show” in the Media Gallery.

    it works fine for me .
    does [gallery] short code works for you ?

    Moderator Andrew Ozz

    (@azaozz)

    WordPress Dev

    That’s strange. Don’t think the js that opens/closes the individual image properties has changed much since 2.6. Could you try another browser? If you’re on Windows there are quite a few that should work well: FF, Safari, Chrome, Opera, IE…

    @astromono

    Update your flash player and Java
    or try the browser upload

    Thanks for the suggestions, I’m running on a Mac, so I’ll try it with Safari and see what happens, don’t know there is a new flash player or java for Firefox 3 for Mac, but I’ll look it up.

    Moderator Andrew Ozz

    (@azaozz)

    WordPress Dev

    BTW Java has nothing to do with Javascript (yes, they sound alike) and is not used anywhere in WordPress.

    I upgraded to 2.7 today and everything seems to be working accept the single image insert. Did not try the gallery yet, but the problem seems the same. I’m stuck at the Show button screen.

    Hi there, I’m having an issue with the insert image option in WP 2.7. Whenever I upload images to use in a post, I go to Insert Image > Gallery and then the list of images pops up, but nothing happens when I click on the “Show” link.

    I see all pictures I uploaded in the Media section, so the upload was okay.

    Also I switched the Tweaks plugin, which previously disabled the flash uploader (didn’t work), on and off. Without any luck.
    I’m working with FF and Mac OSX.

    Alright, I already have the latest Java, so I went and updated Flash to the latest 10.x.x version and then I tried editing an image that I had already uploaded in a draft post, but I couldn’t get it done.

    For some reason, I keep going to the Media Gallery within the post and everytime I click in the Show link, nothing happens.

    @dan.safari, I’m not using the gallery short codes, because the new version of WP changed them, and now I think its [gallery id=x], but im not sure, thats not really the problem i’m having

    @bvm yeah, that’s exactly the problem I’m having! I think we’re close to calling it a Mac OSX-only bug. 🙁

    Moderator Andrew Ozz

    (@azaozz)

    WordPress Dev

    The Show/Hide seems to be working well here in both Safari 3.2.1 and FF 3.0.4 on Leopard (10.5.5).

    @astromono: no, the [gallery] shortcode works exactly like in 2.6, the difference is that in 2.7 there’s an addition to the Gallery tab in the uploader that would allow you to set some of the options for the gallery.

    @azaozz I have the same setup as you do in (Safari, OSX and FF), but still not going anywhere with the show/hide. Perhaps it’s plugin or maybe the installation I did?

    @astromono I have a similar set up. I’m able to see the image by clicking on the ‘show’ link. I can close the post and edit it again and I’m able to get to the image.

    As for the gallery, now I’m making progress. In the previous version when I clicked ont he gallery tab I did not get anything; I just got a blank window. Now I get the expected results and I even get the ‘insert gallery’ button but the images do not display on the post…

    @cipote I was able to work with WP normally before I upgraded to 2.7, but I still haven’t got to the bottom of the problem. It affects everything related to the media galleries, including the Next-Gen Gallery plugin.

    I tried deactivating that plugin and trying to edit, but nothing worked.

    I am on MAC OSX and FF. Under 2.6, after inserting an image, moving the mouse over it and then clicking, the image opens (to full size). Under 2.7 that does not work anymore. Can’t open the image as before. Earlier postings still work as before but not the new ones. Otherwise all looks OK.

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘Insert images in WP 2.7 not working’ is closed to new replies.