WordPress.org

Support

Support » How-To and Troubleshooting » “insert image into post” creates a blank screen

“insert image into post” creates a blank screen

  • I am very new to blogging and wordpress…. I’ve been having trouble placing an image in my post so today I purchased WordPress for Dummies and even that didn’t help!!!!!! I seem to upload images from my Mac without problems into the gallery and media library. but whenever I get to the final step- which is the image, title, caption, description, link URL, alignment, size page- and I click insert into post… it generates a completely blank page. just to be clear…. I want my Blog to be VERY simple. All I want to do is place the image within the text of my post. Please help.

Viewing 15 replies - 1 through 15 (of 46 total)
  • MKatLarge
    Member

    @mkatlarge

    I have the same problem.
    I finally had to copy the URL from the Media Library and insert it using the other “insert image” button, which requires a URL… very frustrating!
    I have this problem both on wordpress.com and wordpress.org, and on both a PC and a Mac.

    Thanks for that idea… and it did work but there MUST be an easier way. Also, I have noticed that there are permalinks established for the images in my media library which look great when opened. But how do people reading the blog get to the permalink ????

    Edwin
    Participant

    @kingbolo

    Same problem here.

    I am running a blog that is hosted elswhere.

    Strange thing is that it happens when I login from the office, either with my desktop or my laptop. When I tried from home it worked fine.
    And Ayrhahm is right there should be an easier way. Or better: it should work as intended.

    I already tried an solution that is mentioned on nineteenhundredandyesterday.com
    But that worked just a few times. Today its the same problem.

    But does anyone have a solution?

    I had this problem for awhile, too, and can’t remember where i found the solution but :

    it seems to have to do with the path you use to login; when I changed my URL to mydomainname.com/subdirectory-if-you-use-one/wp-admin the whole issue went away. and this happened to me with several sites i work on.

    Same problem here …

    Yeah, same problem here. It’s driving me batty. I have multiple WP blogs. Successfully did everything with 2 of my blogs. This new blog is wacked, though, the image thing isn’t working at all. Worked yesterday with my other blogs, so don’t know why this one is being cranky. Anyone got any help? I can’t even get the workaround above to work, as the insert image thing shows up blank most of the time too.

    Batty, people, batty. I’m losing hours of my life to this problem. What gives? The message from the moderators from two months ago saying “not all problems can be solved. Patience.” is not comforting me right now. I’ve tried the fixes in the sticky. Nada.

    A-HA! I finally solved this one. I installed 2 blogs yesterday, and one was working fine, the other was not. Same files, same host, same brand-new install that requires drag and drop, so there’s not much room for error. But one was working (could add photos to posts) and one was not.

    Figured out: the one that was working had an admin page set up as:
    http://www.ADDONDOMAIN.com/wp-login.php

    while the one that was broken was set-up as
    http://www.MAINDOMAIN.com/ADDONDOMAINFOLDERNAME/wp-login.php

    If I login to the broken one using the http://www.ADDONDOMAIN.com structure, all is right in the world again.

    Ahhhh.

    Has anyone resolved this problem? I never had any trouble with images, but I upgraded to 2.7 today and now can’t attach an image to a post.

    I have no trouble uploading images into the Media Library. They all upload and I save them with titles, captions and descriptions.

    But then when I try to insert an image into a post it doesn’t work. It’s just like previous people described:

    When editing a post I put my cursor where the image should go, then click the icon for Add an Image (next to the Upload/Insert label).

    Then I select Gallery, and Show the desired image. I pick the alignment (doesn’t matter which I pick) and size (I’ve tried both full size and the thumbnail).

    After pressing “Insert into Post” the window goes blank. It still says “Add an Image” in the title bar. Nothing is inserted into the post.

    One thing I noticed however, is that when I look at the Media Library now the image I’m working on has been “Attached to” the proper post. Not sure what that means, but I’d really like to get it into the post properly.

    Any ideas?

    Someone help – please!

    This is an old thread, before the 2.7 release, so I’m hoping someone may have discovered a cure in the past six months.

    No matter how I insert an image into my blog (“From Computer”, “From URL”, “Gallery”, or “Media Library”), the “Add an Image” window generates a blank screen when I click the button to insert the image. The only inconsistency is that through it’s “From URL” page, the insert button does nothing. The other pages generate a blank.

    This is driving me nuts. I’m using a clean install of WordPress 2.7. I’m hosting at Pair Networks (www.pair.com). I have WordPress installed on multiple domains, all configured the same (WordPress in the root; no subfolder). The problem is 100% consistent across all domains/installs, as well as on Safari and Firefox under Mac OS X 10.5.5, and Internet Explorer 6 and FireFox under Windows XP Pro. All domains, all platforms, all browsers.

    At this point in time, I am completely, 100% unable to insert an image into a blog post using WordPress. This is a major freakin issue and I can’t believe it’s taken so long to be resolved.

    Am I missing something? None of the solutions have worked for me.

    Dan

    Correction: the only way I can do this is to manually type in the HTML code and bypass the visual editor entirely.

    What in the heck am I doing wrong??

    fredmiller
    Member

    @fredmiller

    I’ve been waiting and waiting for an answer, also.

    I’m running OSX and have tried all the above and more.

    Doesn’t anyone from WordPress monitor this?

    I have this problem now on 5 of my blogs. The issue first emerged in 2.5 and continued. At first I thought it was a problem with 1&1 but now I have it on HostMonster in WP2.7 too.

    homebodyblogger
    Member

    @homebodyblogger

    i’m still having the same issue with uploading my images. i want to launch my blog this month, but… i’ve read many threads and there seems to be no resolution to this problem yet

    homebodyblogger
    Member

    @homebodyblogger

    this is the site that i am redirected to when i try to upload images in 2.7, http://swiftphp.com/blog/index.php. when i upload, it acts as if it is crunching and processing my upload, but instead i am redirected to the link above. i am supposed to be able to alter and edit my image information, but that is not the case, please help!

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘“insert image into post” creates a blank screen’ is closed to new replies.