Support » Fixing WordPress » Insert Image button not working (Add Media works for upload, but won't "insert")

  • Resolved Daniel

    (@dan1980)


    Hi guys,

    WP 4.5.1
    Linux Apache
    PHP vers. 5.4+ (5.4.41 I think)
    ImageMagick not installed on this vm
    (just FYI as I noticed a ‘fix’ for similar WP4.5.1 issues this week have included updating ImageMagick)

    Running only a few plug-ins. Have turned “off” TurboEditor in the past (year ago or more) as it was for an old theme and broke a while back. No longer using TurboEditor (incidentally, it was for the “Ariele” theme which is no longer supported).

    Recent upgrade to 4.5.1 (and this possibly occurred after updating to 4.5 but we only noticed it on client’s site now) —- this caused:

    • Inserting images does not work. Page or Post loads, in the editing/WYSIWYG editor the other formatting buttons work fine, but inserting Image button does nothing (no reaction when clicking)
    • Add Media button works to open the upload window, can upload images to site. But then will not “insert” that into the page/post on completion

    What actually happens is this:

    • Click to edit a Post/Page, etc.
    • When the editor loads, the “Visual” tab is actually blank (as if there is no content there)
    • Need to click the “Text” tab to toggle to HTML
    • HTML is visible, no problems (can edit it and Update, no problems)
    • Toggle back to “Visual” and can see the content there like we normally would (images, etc, all there)
    • However, at this point, it is not possible to click the Image button to insert an image
    • The other formatting buttons appear to work fine (bold, etc)
    • “Add Media” button just above the editor buttons works in the sense that you can upload an image there, but when you go to finalise that so it can insert it into a page, nothing happens. It just returns you to the page/post editing area as though you’ve done nothing (no image has been inserted).

    Has anyone experienced this?

    I’ve been googling for a couple days and trawling all the related posts here in the WP Support forums, but they only seem to describe similar issues – but not this specific one.

    Any help greatly appreciated.

Viewing 12 replies - 1 through 12 (of 12 total)
  • I hope someone will come to the rescue soon – I’m having the same issues with the added bonus – I cannot switch between visual and text – those buttons get no reaction (

    I’m experiencing the exact same thing as Bobbiwired. I can’t insert images into posts or pages and can’t switch between visual and text.

    I hope someone can help soon otherwise it’s pointless to have a website that is unusable!

    Interesting…. Yeah toggling between “Visual” and “Text” is no problem for me.

    Does it happen to you where at first “Visual” is just blank/empty? Or do you actually see the editable contents of your page there (and you just can’t toggle between visual/text in addition to not being able to “Insert Image”?)

    I can also confirm that practically nothing works in the WYSIWYG editor. No formatting, bolds, italics, insert image, change colour, insert link … nothing. None of the buttons react when clicked.

    I can also confirm I have 2 sites with this problem running on separate servers (Plesk and the other cPanel) and both have are experiencing the same problems.

    I think i just figured it out. I read somewhere to deactivate headspace2 so I tried that and it works perfect now.

    Daniel – I was editing an existing page, so the info was already there – no blank screen in visual.
    I deactivated headspace 2 too, and mine is working fine now too!! Yippee ;D

    headspace2? Is that a plug-in?

    Hmmm…. I haven’t got that plug-in installed.

    Does anyone else have any suggestions?

    Ok, I’ve discovered the problem for our 2 sites with this issue is these 2 plug-ins (both simultaneously causing an issue):

    • Akismet
    • Yoast SEO

    Incredible!

    There are discussions in their respective forums about this issue for both these plug-ins in the past week:

    https://wordpress.org/support/plugin/wordpress-seo
    https://wordpress.org/support/plugin/akismet

    Hope this helps someone else who has a similar issue.

    It is a bug in wordpress. I did a clean install on a local server and the error persists.

    Yeah but nobody wants to admit that…..

    I seriously have to convince this client to move over to Joomla. Even though it’s had it’s fair share of issues, I have to say after our team has worked with WP and Joomla for the past 8 years … when WP has a problem – it really has a problem – and it takes forever for them to admit to it. Just our / my opinion based on our experience.

    FGD

    (@creativetopia)

    I found this to be a bug with this specific plugin – https://wordpress.org/plugins/wp-opening-hours/

    I had this problem yesterday. The previous day the image upload and switch to text editor was working fine. Then both stopped working. I tried all sorts in an attempt to fix it; disabling plugins, reinstalling, fiddling with my router, but the problem persisted. So I went to the pub to have a think and, bingo, when I returned it was working. I was able to upload images and switch from to text view without any problem. Very strange. Nothing had changed my end. So my solution is a pint of real ale – worked for me.

    • This reply was modified 3 years, 6 months ago by helpingmedia.

    I had this same problem and I was tearing my hair out – no console errors, not much to go on. My problem was with a custom plugin I’d written, which adds a custom meta box to posts and lets you attach different images to the post (in this case, ‘app icon’, which we wanted to keep separate from Featured Image). This plugin contains some JS which hijacks the ‘Insert Into Post’ target.

    Offending code:

    
    window.send_to_editor = function (html) {		
      var imgurl = $('img', html).attr('src');		
      updateImageField(imgurl);		
      tb_remove();		
    }
    

    So now I make sure I make a copy of the state and revert back to it once I’m done.

    
    breakAddMediaBehaviour();
    window.send_to_editor = function (html) {		
      var imgurl = $('img', html).attr('src');		
      updateImageField(imgurl);		
      tb_remove();		
    }
    
    // then a bit later:
    restoreAddMediaBehaviour();
    
    // here's where the 'magic' happens:
    
    function breakAddMediaBehaviour() {
      window.prev_send_to_editor = window.send_to_editor;
      window.prev_imageFieldToUpdate = window.imageFieldToUpdate;
    }
    
    function restoreAddMediaBehaviour() {
      window.send_to_editor = window.prev_send_to_editor;
      window.imageFieldToUpdate = window.prev_imageFieldToUpdate;
    }
    

    Thought I’d share in case it’s useful to anyone else.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Insert Image button not working (Add Media works for upload, but won't "insert")’ is closed to new replies.