Support » Plugin: Before + After Images for Divi » “Insert from URL” images do not appear

  • jasonbear

    (@jasonbear)


    Hey, Aaron,

    Up to this point, I’ve been using images that are hosted in my Divi library. I’m now moving all images to my remote CDN. Today, after I used the “Insert from URL” feature to insert CDN images, the image(s) stopped appearing on the front end. There is just a blank space where the image(s) used to appear. The image(s) DO still appear in Divi’s visual editor, though. Any idea why this is happening?

    NOTE: All other CDN images appear on the front end of my site just fine; it’s only the “Before + After Images for Divi” images that are missing/blank.

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Aaron Bolton

    (@boltonstudios)

    @jasonbear Hi Jason, Thank you for reporting this. I confirmed that the plugin does not work with insert from URL, as you said. In the plugin directory > Includes > Modules > BeforeAfterImage > BeforeAfterImage.php, there is a bunch of code in the render() function that attempts to process the $src variable using built-in WordPress functions that search for assets in the Media Library. I’ll have to add logic for dealing with an external image such as from a CDN.

    Interestingly, CDN plugins such as Autoptimize that convert all asset links to CDN links do not break the before/afters. Here is an example of a bunch of before-after images with all links loaded from a CDN: https://www.owingsbrothers.com/gallery/bathroom-remodeling/. Those images were added to the media library first, not using Insert URL. I’ll keep this in mind for a future update. I do not have a solution at this time. If I don’t hear from you soon, I’ll go ahead and close this ticket. Thanks.

    Plugin Author Aaron Bolton

    (@boltonstudios)

    @jasonbear FYI I replied but the message is being held for moderation.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘“Insert from URL” images do not appear’ is closed to new replies.