Support » Fixing WordPress » Insecure content error, but not showing up on WhyNoPadlock

  • I just converted my sites to https. On one site, I have no green padlock after I’ve converted files, run the SSL Insecure Content plugin, and have checked the site on WhyNoPadlock. WhyNoPadlock says that all 193 items are secure, but I’m not getting the green padlock. This is while using Firefox.

    WhyNoPadlock tells me that on Chrome I would get…

    Insecure <form> call.
    Found on line # 390 in file: sallieborrink.com/index.html

    (Note: Chrome will show a security error for any secure page with an insecure <form> call on the page)

    Okay, but my site has no index.html file at root level. If for some reason I need to fix this, I have no file to edit. So I don’t know if this is a false positive on Firefox, or if Firefox is picking up on the error that Chrome is supposed to have.

    I looked at the site in Chrome, and in the source code, line 390 has no form elements. I tried another page and ran the WhyNoPadlock test, it gives the same error for Chrome but on a different line number. Again, the source code has no form elements on that line.

    Any suggestions what I could do to resolve this?

    Site link.

    • This topic was modified 3 years, 9 months ago by David Borrink.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi

    The problem is with this js file…

    <script id="mNSC" src="https://contextual.media.net/nmedianet.js?cid=8CU7N0J5R" language="javascript"></script>

    Debugging the your home page shows:

    Loading mixed (insecure) display content “http://qsearch.media.net/nerrping.php?d=%5B%7B%22logLevel%22%3A3%2C%22errorVal%22%3A%7B%22name%22%3A%22Error%22%2C%22message%22%3A%22Error%20loading%20L2%20Url%20with%20host%20http%3A%2F%2Fcontextual.media.net%22%2C%22line%22%3A1%2C%22stack%22%3A%22ot%40https%3A%2F%2Fcontextual.media.net%2Fnmedianet.js%3Fcid%3D8CU7N0J5R%3A1%3A42240%5Cnst%40https%3A%2F%2Fcontextual.media.net%2Fnmedianet.js%3Fcid%3D8CU7N0J5R%3A1%3A42437%5Cnie%2Fthis.bootstrap%40https%3A%2F%2Fcontextual.media.net%2Fnmedianet.js%3Fcid%3D8CU7N0J5R%3A2%3A178%5Cnoe%40https%3A%2F%2Fcontextual.media.net%2Fnmedianet.js%3Fcid%3D8CU7N0J5R%3A2%3A345%5Cnl.execSafe%40https%3A%2F%2Fcontextual.media.net%2Fnmedianet.js%3Fcid%3D8CU7N0J5R%26https%3D1%3A1%3A12502%5CnS%40https%3A%2F%2Fcontextual.media.net%2Fnmedianet.js%3Fcid%3D8CU7N0J5R%3A1%3A21698%5Cnz%40https%3A%2F%2Fcontextual.media.net%2Fnmedianet.js%3Fcid%3D8CU7N0J5R%3A1%3A22291%5Cn%40https%3A%2F%2Fcontextual.media.net%2Fnmedianet.js%3Fcid%3D8CU7N0J5R%3A2%3A41131%5Cn%40https%3A%2F%2Fcontextual.media.net%2Fnmedianet.js%3Fcid%3D8CU7N0J5R%3A2%3A37620%5Cn%22%7D%7D%5D&userAgent=Mozilla%2F5.0%20(Windows%20NT%2010.0%3B%20WOW64%3B%20rv%3A54.0)%20Gecko%2F20100101%20Firefox%2F54.0&requrl=https%3A%2F%2Fsallieborrink.com%2F&img=logo.gif” on a secure page[Learn More]

    So its the http://www.media.net/ ad code that’s the problem.

    Thanks, Eddy, for doing that. How did you get that info? I’m not familiar with what it would take to get that info. I see the Console and Debug Info tabs, but what did you do to get that info to come up?

    Hi

    Use Firefox Developer Edition, has some nifty tools for debugging.
    You can check out the features @ https://developer.mozilla.org/en-US/docs/Tools

    Wow. Thanks for the tip. And thanks again for determining it’s Media.net. It’s clear that it’s info that comes from them, so we’ve contacted them for a solution.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Insecure content error, but not showing up on WhyNoPadlock’ is closed to new replies.