Support » Plugin: WooCommerce Stripe Payment Gateway » Input Fields not showing

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Praveen

    (@spraveenitpro)

    Automattic Happiness Engineer

    Hi @montey11 ,

    I see that you are facing a situation where the credit card fields are not appearing and the icons look very large. I checked your site and saw it firsthand.

    Most of the time, issues like this are coming from the custom theme you are using or one of the plugins that you may have installed/activated.

    I would recommend deactivating all the plugins except for WooCommerce and stripe followed by checking if the behavior persists. if the situation goes away then activate plugins one by one to check which one is causing this. Do the same for the theme by switching to Storefront theme (https://wordpress.org/themes/storefront/). More on this method at https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    Cheers!

    thank praveen.

    It is putting <!– a Stripe Element will be inserted here. –> instead of the input fields, no input fields are showing at all. What kind off issue in the theme would make the plugin do this?

    Thanks

    KingDingbat

    (@kingdingbat)

    As evidenced by the many other posts about this very same problem, also answering that they’ve disabled plugins and tried the Storefront theme it is NOT the theme. This is a problem with the gateway and Automattic needs to own up to it and fix it instead of trying repeatedly to blame other software for conflicts that don’t exist.

    I am using a clean install of WordPress, WooCommerce & the Storefront theme, and only the Stripe payment gateway and this is what the form looks like: (No fields)
    Screenshot (inline enabled): http://prntscr.com/rlknid
    Screenshot (inline disabled): http://prntscr.com/rlkoki

    I’ve tried multiple versions of the default wordpress theme (2019, 2020, 2017) and the Storefront theme. All other plugins except Woocommerce and the Stripe gateway are disabled.

    Plugin Support AW

    (@slash1andy)

    Automattic Happiness Engineer

    @montey11 I just checked your site again, and it looks like your fields are showing up well and the card icons are appropriately sized. The message you mention ( <!– a Stripe Element will be inserted here. –> ) typically means the plugin is active on the site without credentials being input. It looks like you have testing/sandbox credentials in place now.

    @kingdingbat please open a separate forums post here if you are having an issue with the Stripe plugin (even if it sounds similar to one that someone else is having). You can check my message above to see if that helps, and if not, please open another post.

    Hopefully that helps! Have a great one!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.