Support » Fixing WordPress » InnoDB versus myISAM

  • Resolved PetLvr


    Half of my blogs are on a host provider that has been plaguing me with slow activity and downtime. I have obtained another host provider and was in the process of converting … I have setup name servers, FTP’ed my entire site over, make a backup of the mySql database of the OLD blog and … then I get errors.

    I contacted the new host provider and this is what they said:

    Your database is not being populated with the backup provided because it is written for the InnoDB MySQL engine. Unfortunately we do not support InnoDB, but MyISAM.

    Is there a way around this? Or, did I just waste money on a new host provider?

Viewing 15 replies - 1 through 15 (of 17 total)
  • I hope everybody is busy with version 2.0 and that is why there is no responses to this question, otherwise I would be really concerned if I am unable to move one mysql database to another server (or the information in that database I should say …




    If you look at your database export, you should (hopefully) see something like this at the end of each CREATE TABLE stanza:

    Try changing those from InnoDB to MyISAM. Good luck.

    Thanks Skippy!

    I never noticed that during the export but will retry the export now..

    I’m sad to say that this has not worked for me, because I was
    unable to see anything that mentioned either types…

    I did obtain the following information that I hope might help:

    Screen capture image during the export process?

    Existing – where database currently resides:
    phpMyAdmin 2.5.2-pl1 MySQL 4.1.10a

    NEW location – where I want to restore database:
    phpMyAdmin 2.6.4-pl2 MySQL 4.0.25-standard

    (if that means anything to anybody)




    Once you export the database, you should have a plaintext file filled with SQL statements. It will be in this file that you’ll find the ENGINE= bit that I mentioned above. You won’t see it until you export the database to a file. Open the file in your favorite text editor, and search for InnoDB. Replace with MyISAM. Repeat as necessary.

    Hi again Skippy.

    I think I’m almost there. I replaced all the InnoDB to MyISAM.
    It’s still giving me errors though, on the last line which the
    above “ENGINE=” was included…..

    This is after the error message was received, shown in the SQL box:

    moon_categories (

    cat_ID bigint( 20 ) NOT NULL AUTO_INCREMENT ,
    cat_name varchar( 55 ) NOT NULL default '',
    category_nicename varchar( 200 ) NOT NULL default '',
    category_description longtext NOT NULL ,
    category_parent int( 4 ) NOT NULL default '0',
    cat_ID ) ,
    category_nicename ( category_nicename )

    This is the error message below it that was received:

    MySQL said:
    #1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1 AUTO_INCREMENT=18' at line 9

    That is just an example of copy/pasting one table at a time….


    I think you just need to make that one little ‘Y’ lowercase.

    Mark (podz)


    Support Maven

    If that does not work, do a search/replace on the sql file and replace this
    with nothing.

    Jalenack – I had originally converted the MyISAM but it was
    replaced with MYISAM in the error message only.

    PODZ! IT WORKED! .. but my blog is still not up.

    I have been able to restore everything. But I am still getting
    the following message .. it’s at

    Warning: main(/home/newmoon/public_html/wp-includes/wp-db.php): failed to open stream: No such file or directory in /home/newmoon/public_html/wp-settings.php on line 59

    Fatal error: main(): Failed opening required '/home/newmoon/public_html/wp-includes/wp-db.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/newmoon/public_html/wp-settings.php on line 59

    My gut feeling is that there is now two major issues that are
    part of my problem:
    (1) my old database of “newmoon” is now under a new database
    name of “newmoon_newmoon” … and my e.g. “userID” is now under
    a new userID of “newmoon_userid” …
    (2) I’m not sure if the ‘real’ path is an issue or not, but being
    on another host provider, surely it is different?

    Is there anymore tips or suggestions that you can provide me?

    Thanks // HART

    I do not know how to change that path listed above as (include_path=’.:/usr/lib/php:/usr/local/lib/php’) ….

    although I found this .pdf that suggested I modify the moon_options
    table (which was that actually) to it’s new place ..
    I changed it from above to this …. /home/newmoon/public_html/wp-includes (which although this was already listed or ‘intuitively’ figured out

    But the error message is identical to that I posted previously.

    I did find out one strange thing. I know someone at a different location
    that apparently can still see this site in its’ old location. I
    just changed the nameservers wednesday morning. I was seeing the
    new site Thursday morning.

    EDIT/ Sorry if I sound needy and anxious, except that is 100% true – I am. I thought this was supposed to be easy to transfer? I think I’ve followed all the written instructions about this. And, I’m still down. This blog has 5 transactions. I hope to be moving other blogs that ranges between 50 and 900 posts.

    Do you have shell access to this provider? If so, is it possible to pull the logfiles for apache to see if there may be any additional data available? The error being reported is an access error — it has nothing to do with the database.

    Hi dm reiland … I posed the question to my new host provider..

    After you have submitted photo identification, update this ticket and we will be happy to enabled ssh access on your account.

    Though, you will not be able to pull information directly from the apache error log.

    You can though, use the error_log file that will be output in the same directory as your script. Also, there is an error log available through CPanel.

    I probably wouldn’t know what to do anyway – what do you suspect
    might be a way to fix this, if I did have shell access?
    I have copied that error_log file to be readable .. here:
    which pretty much shows what I’ve posted earlier….

    If you have any further inquires, feel free to contact us sooner.

    I think I have figured out what was the problem. wp-db.php was missing altogether.

    As soon as I ftp’ed this file into the wp-includes folder, I got the WordPress error …

    It doesn't look like you've installed WP yet. Try running install.php.

    Rather than close this thread – I now ask your further advice …… Why is it asking me to install ?? The mysql database should be there already, right? All the tables exist now … so, why is it asking me to install again?

    And – what would happen if I were to install again? The tables exist – how could it create it again? The whole point was supposed to be so I don’t have to reinvent the wheel again .. if I create, wouldn’t I have to recreate everything??




    Does your wp-config.php file contain the correct username, database name, and table prefix? The latter two need to match the data you imported.

    my wp-config.php file definately contains the correct username, database, and passwords … (this changed from old database to new database)

    The table prefix is the same that it was in the old database .. this doesn’t appear to have changed when I restored each table .. they each have the same “moon_” prefix, which is in the wp-config.php file.

    Everything “looks” normal.

    What would happen if I were to click on that /wp-admin/install.php file on an existing database and tables that were restored in my adventure? (I haven’t done that btw)

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘InnoDB versus myISAM’ is closed to new replies.