Support » Plugin: Email Before Download » inlink download not showing

  • Hi,

    i set to both email and inlink after submit email, but inlink does’t show any download link, only email can receive the pdf file. may i know how to solve this?

    [Link removed by moderator]

    • This topic was modified 1 year, 6 months ago by  Steve Stern.
Viewing 15 replies - 1 through 15 (of 20 total)
  • I’m having this issue as well. Neither the “inline” or “both” option are displaying the download link upon submission in version 5.0.9. Also, there is a red bordered box that is displaying at the bottom of the form, with class “wpcf7-response-output wpcf7-display-none”. Can you please resolve this ASAP? My clients are currently not able to access the downloads.

    Also, 5.0.4 was working for me. My hosting company automatically updated me to 5.0.9. Would there be a way to create a download link for 5.0.4 that I can use to downgrade if you’re not able to resolve these issues today?

    Plugin Author mandsconsulting

    (@mandsconsulting)

    Hello @francisbeh ,@mbansak

    These issues are most likely do to the new version of Contact Form 7. They have deprecated some of the settings EBD was using to serve your links. The newest update of EBD, 5.1.0, should solve these issues.

    yes, is EBD version problem, the issue fixed after update. thanks

    I was experiencing the same issue as the others, and I just updated to v 5.1.0. Now, instead of nothing happening after the contact form is submitted, I’m getting the following message:

    no data found

    This appears just below the “Thank you” message.

    For a few more details, I’m getting the following json back from the cf7 feedback endpoint (/wp-json/contact-form-7/v1/contact-forms/1806/feedback).
    {"into":"#wpcf7-f1806-p1797-o1","status":"mail_sent","message":"Thank you. Your download link is below."}

    I notice that this json is missing the onSentOk parameter which I’m seeing on your test site. Is there something that I’m missing? The json returned on the demo site follows for comparison:

    {"into":"#wpcf7-f3186-p14628-o1","status":"mail_sent","message":"Thank you. Enjoy the download.","onSentOk":[" jQuery('#wpcf7-f3186-p14628-o1').append('<div><span class=\"et-icon\"><span><a href=\"https:\/\/www.mandsconsulting.com\/wp-json\/ebd\/file\/d384a4330e\" class=\"icon-button download-icon ebd_link \" target=\"_blank\">email before download live demo - test download<\/a><\/<\/span><\/span><\/br><\/div>'); "]}

    If it helps, this is the site I’m testing on:

    http://www.steelbridgesolutions.com/perspectives/successful-change-management/

    Thanks!

    • This reply was modified 1 year, 6 months ago by  cmborchert.
    Plugin Author mandsconsulting

    (@mandsconsulting)

    @cmborchert

    Yes, someone else has posted a similar issue.

    could you tell me what version PHP you’re running.

    The onSentOk has been deprecated by Contact Form 7 in their newest version, so that would only apply if you’re running the older version of CF7.

    Thank you for the prompt reply @mandsconsulting!

    We’re running php 5.4.43 with CF7 v 5.0.

    Thanks

    Oskar Gómez

    (@oskargomezmartin)

    Hi!

    Thanks for plugin and support!!

    I just have updated to ebd v5.1.0 and the same issue that cmborchert (@cmborchert), inline links doesn´t work and the same message:

    “no data found”

    CF7 v 5.0
    php 5.6.30

    Kind regards

    Plugin Author mandsconsulting

    (@mandsconsulting)

    @cmborchert, @oskargomezmartin

    These issues should be resolved with the new version v5.1.1

    Thank you for your patience.

    Thanks @mandsconsulting !

    The no data found error has gone away, but I’m still not getting the download link to appear. Is there anything I can do to help test this?

    Plugin Author mandsconsulting

    (@mandsconsulting)

    @cmborchert

    could you check your wp-config.php file and see if WP_CACHE is set?

    Thanks @mandsconsulting

    WP_CACHE is not set in wp-config.php.

    Plugin Author mandsconsulting

    (@mandsconsulting)

    @cmborchert

    Could you add this line to your config?

    define('WP_CACHE', true);

    See if that solves the issue.

    Still no luck, even with WP_CACHE turned on.

    Is there anything in the request/response to ajax-admin.php or feedback that could be helpful to you?

    @mandsconsulting

    Here’s a small update:

    It seems like the transient is never getting set in the Email_Before_Download_Process class because $settings['delivered_as'] is not set. Looking into the out the $post_data['ebd_settings'], I got the following values:

    form_id: wpcf7-f1806-p1797-o1
    item_id: 2
    from_name: “”
    radio: “no”
    checked: “no”
    title: “My Title”

    It seems like the option is not being set.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘inlink download not showing’ is closed to new replies.