Support » Fixing WordPress » Inline-Uploading error

  • Every time I try to use the built in upload utility, i get the error message that the file has been partially uploaded.

    I check the permissions on the upload directory, they are set perfect. I have a ton of HDD space on my server, there are no file number restrictions, and no errors popping up in my error log on my Linux box.

    My host and I are baffled by this problem, since it is generating no errors. I added nothing or customized my WP install to trigger this problem to happen and I hope someone can help!

Viewing 13 replies - 1 through 13 (of 13 total)
  • wp-content/uploads should be 777 (you didn’t say, but I want to be clear).

    Is a file created at all?

    The directory is set to 777.

    Any file that I attempt to upload is never makes it to the server.

    Try using FTP?

    FTP works fine, but it is a pain in the ass compared to the easy inline uploader.

    It seems to be a WP issue that I can’t solve!

    I suspect it has more to do with your server’s method of mapping the PHP script doing the uploading to a unique user.

    When you FTP in, everything you do is assigned the user you logged in as (hence the test I suggested). When a PHP script executes (for security reasons) the process is assigned a unique user (and group, usually). Usually manipulating file/directory permissions addresses this.

    I have no idea why it doesn’t work for you…

    If you want any more help troubleshooting this I suggest you share more details about your host/environment (What host? What version WP? A link to site, etc., etc.).

    Well, I didn’t want to do anything to look like I was spamming this site.

    The Host is Hostway, using Linux (Finding out what version). WP version 2.0.3.

    It just happened very suddenly.

    It just happened very suddenly.

    Oh? It used to work at this host? So what changed between then and when it stopped working?

    If you didn’t change anything, did your host?

    Nothing changed. Honestly nothing. I have plenty of HDD space. Didn’t change any permissions. No updates, no plugins. It is so very off.

    I am suddenly having inline uploading problems as well. Two days ago when I uploaded some images, everything worked just fine. Yesterday, nothing. When I click upload, nothing happens and eventually it times out with this message:

    Cannot Load Address

    Stopped loading <http://myaddresswashere/wp-admin/inline-uploading.php&gt;: lost network connection

    I have restarted browsers, used different browsers, restarted the client machine, restarted apache, and restarted the web server itself. Still no joy.

    No changes whatsoever. I’m in Mexico, server is in Vermont. Routers are unchanged on both sides of the connection. I can upload to the server directly via sftp, but the inline function refuses to work.

    Glad there are two now!

    another issue about Inline-Uploading error: I upgraded to 2.0.5 and not just after the upgrade but few days later, I’m experiencing strange behaviours like I cannot send to the editor the image correctly loaded. I tried to upload again both post.php and inline-uploading file but..nothing

    anybody knows?

    ok resolved! it is the edit-form-advanced that was corrupted.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Inline-Uploading error’ is closed to new replies.