Support » Plugins » inline more plugin causing errror

  • I’m using Chroder’s collapsible More link plugin, and I love it, but it seems to be causing an error on my site—an error which does not appear to be on Chroder’s site, even though he is using the same plugin.

    When I validate my site, it gives me 3 errors per post that seem to be caused by this more link.

    Here are the errors:

    1.

    document type does not allow element “div” here; missing one of “object”, “ins”, “del”, “map”, “button” start-tag.

    <div id="more_content_227" style="display:none;">

    The mentioned element is not allowed to appear in the context in which you’ve placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you’ve forgotten to close a previous element.

    One possible cause for this message is that you have attempted to put a block-level element (such as “<p>” or “<table>”) inside an inline element (such as ““, “<span>”, or “<font>”).

    2.

    document type does not allow element “div” here; missing one of “object”, “ins”, “del”, “map”, “button” start-tag.

    <div style=”text-align:right;”>

    The mentioned element is not allowed to appear in the context in which you’ve placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you’ve forgotten to close a previous element.

    One possible cause for this message is that you have attempted to put a block-level element (such as “<p>” or “<table>”) inside an inline element (such as ““, “<span>”, or “<font>”).

    and

    3.

    end tag for “p” omitted, but OMITTAG NO was specified.

    </div>

    You may have neglected to close an element, or perhaps you meant to “self-close” an element, that is, ending it with “/>” instead of “>”.

    Is this something simple? My theme was 100% valid until I started adding plugins. Is it possible the plugins aren’t compatible with my theme?

Viewing 1 replies (of 1 total)
  • Nevermind, fixed it!

    I had to enter twice at the end of my post and around the “inline more” words, to insert the proper p tags.

Viewing 1 replies (of 1 total)
  • The topic ‘inline more plugin causing errror’ is closed to new replies.