Support » Plugin: Email Before Download » Inline link not appearing

  • Resolved bonter

    (@mattshawuk)


    Hi,

    I’ve been alerted to the fact that the inline download link is no longer showing after filling in the form. I’ve checked that the shortcode is correct and the IDs are pointing to the right places, and I cannot see anything going wrong in the console, so just wondering if you’re able to identify what’s going on here?

    Thanks in advance for any help you can provide!

    Matt

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 29 total)
  • Hi,

    We had the same issue, after some investigation, it turned out to be an issue relating to the latest version of Contact Form 7 (version 5.4). If you are using this version, try rolling back to (version 5.3.2) this worked for us.

    Ian

    Thread Starter bonter

    (@mattshawuk)

    Hey Ian,

    Thanks so much for your response (and by the look of things creating an account to do just that!) Rolling back has indeed fixed the issue.

    I don’t want to mark this as resolved just yet though – will the developers be addressing this conflict? As I imagine it’s not really down to CF7 to fix a conflict with an extension?

    Thanks again!

    We’ve got the same issue and can confirm it’s the CF7 version. We really don’t want to downgrade it for security and other integrations we have working with it.

    Has anyone had any word from the developers, or found any workaround that doesn’t involve knocking the plugin or CF7 down to a previous version?

    Thanks in advance.

    Andy

    • This reply was modified 7 months, 2 weeks ago by andyok.

    Ok that explains a lot, I thought I was too dumb to use this. I double checked everything hundreds of times. I was trying to set it up for the first time yesterday and was unaware of the recent incompatibility issues.
    If somebody has a solution (other than downgrading plugins or wordpress) even with other plugins… Thanks for sharing your wisdom!

    • This reply was modified 7 months, 2 weeks ago by arsadka.
    Plugin Author mandsconsulting

    (@mandsconsulting)

    Thanks for contacting us

    Can you verify a few things for us:

    1) WordPress version?
    2) Version of Email Before Download are you currently using? Latest is 6.2
    3) Are you using inline only or emails as well (both)
    4) Any other response from CF7 after email address submission?

    I’ve alerted the team about the issues you’re facing. It sounds like rolling back to a previous version of CF7 is a short-term fix. We’ll let you know with any updates or if we need additional information.

    Thank you for coming to help with this issue

    1. WordPress 5.7
    2. Email Before Download Version 6.2
    3. inline only
    4. no other reponse from CF7 (email is sent correctly, just the inline link doesn’t appear on the page.)

    1) WordPress version?
    2) Version of Email Before Download are you currently using? Latest is 6.2
    3) Are you using inline only or emails as well (both)
    4) Any other response from CF7 after email address submission?

    WordPress 5.7
    EBD v.6.2
    CF7 v.5.4
    Inline

    We’re using the inline link. We ugraded CF7 due to a security issue, so really not wanting to downgrade it.

    Plugin Author mandsconsulting

    (@mandsconsulting)

    Hi all,

    Thank you for reaching out. We are actively looking into this issue and will update this thread as soon as we have an answer.

    Thanks!
    EBD Team

    Thread Starter bonter

    (@mattshawuk)

    Thanks EBD team – I have the same setup as the others too.

    1. WP 5.7
    2. EBD 6.2
    3. Inline
    4. Nothing else from CF7

    No script errors reported by Chrome’s console either as far as I can see.

    Thanks again,

    Matt

    I have the same setup as the others too.

    1. WP 5.7
    2. EBD 6.2
    3. Inline
    4. Nothing else from CF7

    Hi,

    1. WP 5.7, had the same issues with inline with 5.6.2 when using CF 5.4
    2. EBD, 6.2 working fine before the CF update.
    3. Inline, although we tried email and this works fine even with CF 5.4
    4. CF 5.3.2, rolled back, which is working but inline fails if upgraded to 5.4

    Hope this helps

    Ian

    storymark

    (@storymark)

    Hi, downloads have not worked for 10 days. I can see that is all correct, downloads and emails are registred but the link never appeared and the email never arrived.

    1. WP 5.7
    2. EBD 6.2
    3. Inline & email (doesn’t work anyone)
    4. CF 5.4

    Thanks!

    Meg

    (@megortel)

    I am following this thread. We are experiencing the same issue at https://edlawpharm.com/

    1. WP 5.7
    2. EBD 6.2
    3. Inline
    4. CF 5.3.2 (rolled back, thanks to suggestion above, and now working again, but was not working when at 5.4)

    Looking forward to resolution, thank you!

    storymark

    (@storymark)

    Hi, please i need a solution or we’ll need to look for another plugin 🙁

    Seniah

    (@barbarahaines)

    Have been working to resolve this same issue for https://internationalbicycletours.com/request-an-itinerary-2/

    1. WP 5.6.2
    2. EBD 6.2
    3. Inline
    4. CF 5.3.2 (rolled back, thanks to suggestion above, and now working only on some platforms/browsers – specifically Chrome on MacOS)

    Also looking forward to a solution, thank you!

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Inline link not appearing’ is closed to new replies.