Support » Plugin: Autoptimize » Inline & defer | /options.php error | @font issue

  • Resolved AoxoA

    (@aoxoa)


    My issue is actually resolved. However, I wanted to share information on what the error looks like and how it was resolved.

    I encountered the error when using the inline and defer option. I used this guide to inline and defer render-blocking CSS. The error occurred when I used the following as part of my critical above the fold CSS:

    @font-face {
      font-family: dashicons;
      src: url(//aoxoa.co/wp-includes/css/../fonts/dashicons.eot);
    }

    Screen cast of that issue (if you wanted to check it out). https://youtu.be/sVVVydjXIZo

    I am on shared hosting at WestHost. I gave them admin privileges to my WordPress site and steps to recreate the error. They were able to recreate the error on their end.

    WestHost added several ModSecurity exceptions for my site. The ModSecurity IDs that were added into the exceptions list:

    – [id “340007”] [rev “42”] [msg “Atomicorp.com UNSUPPORTED DELAYED Rules: Generic Path Recursion denied”]
    – [id “340361”] [rev “2”] [msg “Atomicorp.com UNSUPPORTED DELAYED Rules: CONNECT method denied”]
    – [id “340195”] [rev “1”] [msg “Atomicorp.com UNSUPPORTED DELAYED Rules: Possible Base64 Encoded PHP function in Argument – this may be an attack.”]
    – [id “340162”] [rev “287”] [msg “Atomicorp.com UNSUPPORTED DELAYED Rules: Remote File Injection attempt in ARGS (AE)”]
    – [id “222050”] [rev “4”] [msg “COMODO WAF: Directory traversal vulnerability in the Slider Revolution (revslider) plugin before 4.2 for WordPress (CVE-2014-9734)||aoxoa.co|F”]
    – [id “330045”] [rev “3”] [msg “Atomicorp.com UNSUPPORTED DELAYED Rules: Suspicious Unusual User Agent (pycurl). Disable this rule if you use pycurl. “]

    If you run into the same type of error you now have an idea on how to resolve it.

    • This topic was modified 1 year, 2 months ago by  AoxoA.
Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Inline & defer | /options.php error | @font issue’ is closed to new replies.