Support » Plugin: Widgets for SiteOrigin » Inked Blog linking issue

  • Hi,

    Using the free version of Inked Blog… The Read More button only links to the page the widget is on but not to the correct blog entry/post.

    I have this problem since the last Update to the newest Version 1.3.7.
    Would be nice, if there would be any advice, or help with the bug or Update which resolves the problem.

    I tried to get an answer on the forum on http://www.wpinked.com, but did not get an answer for one week now. Mor people seem to have the same problem. I am not the first who writes on the forum on the developer website on this topic.

    Regards

Viewing 6 replies - 1 through 6 (of 6 total)
  • Yes! Thank you I am having same problem … this is not a minor concern but have several clients complaining.

    Inked dev please respond? Is this something that can be easily fixed?

    Ah, this was causing me too much grief – so I just jumped into the code. Turns out it’s a fatfinger issue on their dev side, so an EXTREMELY easy fix! 🙂

    Here’s how to correct the issue: Go into /widgets-for-siteorigin/widgets/ink-blgs-widget/tpl directory. There you’ll see a PHP file for each type of blog layout; no image, image left, above, etc.

    Do a search for btn-text and you’ll be shuttled down to around line 160 to 170 or thereabouts. Now, just a line or so above that, you’ll see this:
    <a class="<?php echo esc_attr( implode( ' ', $btn_class) ); ?>" href="<?php esc_url( get_permalink() ); ?>">

    This is the line of code that puts the classes and permalink to the post into the a tag. But you notice that code after href=? It’s broken … they somehow deleted or forgot to put in the echo that would actually spit it out. So just update that line to look like this and you’re good:

    <a class="<?php echo esc_attr( implode( ' ', $btn_class) ); ?>" href="<?php echo esc_url( get_permalink() ); ?>">

    So glad it was such an easy fix, and hope this answer helps someone else!

    Thanks for that Michael.

    I’ll hope this will be fixed soon.

    Thanks @mkastler. That was it! Easy quick fix.

    • This reply was modified 1 year, 3 months ago by timnancyk.
    Plugin Author Adi Rao

    (@iamadi)

    Sorry guys. I’ll update the plugin with a fix tomorrow.

    Thanks @iamadi – happy I could help 🙂 Love the plugin, hope you can keep up the good work!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Inked Blog linking issue’ is closed to new replies.