Support » Fixing WordPress » Initial page slow to load

  • agm285

    (@agm285)


    I have a speed issue, but apparently it’s different from the normal speed issues I see described.

    If I haven’t visited the site in, say, a day, the first page of the site I view, regardless which page, takes about 20 seconds or more to load. Once that loads, I can bounce around on the site just fine, with pages taking less than 2 seconds to come up. After another day or so, the first page I view takes 20 seconds again. This means people viewing it from a Google search are probably going to give up.

    I thought it might be an image caching problem but it’s not. If I clear the cache (in Chrome it’s Settings, Clear Browsing Data, Cached Images and Files) then the next page loads in about 3 seconds. And then they go back to 2 seconds. It’s a relatively small site. About 8 separate Pages, and about 20 Posts. The site is hosted by Network Solutions. Maybe that’s an issue.

    We’ve tried W3 Total Cache and Jetpack which offers some speed options. Helped the subsequent pages but not that initial load speed.

    The site is alps-tours.com.

    I’d also be interested to hear a few responses just stating what your experience on the site was. Initial delay, or no?

    Thanks for any suggestions you can offer!

    • This topic was modified 5 years ago by agm285.
    • This topic was modified 5 years ago by agm285.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator t-p

    (@t-p)

    Slowness/high CPU usage could be due to (but not limited to):
    – A poor or memory intensive theme. Switch to the WordPress default theme and test loading time and see if you see a difference. If you do, may be your theme can be re-written to be more efficient.
    – Poor or memory intensive plugins. One by one disable plugins and test loading time and see if you see a difference. If you do, may be that plugin can be re-written to be more efficient.
    – your server is slow (e.g., “process hang”, overload, you get a lot of visitors, other problems, etc.); generally, every inexpensive host out there is slow.
    – I don’t know if you use CloudFlare or not but if you do I would suggest deactivating it and seeing if it helps. Also sometimes a good purge of the cache on CloudFlare can help.
    – Lots of images can cause slowness. Also images loaded without compression.
    – Lots of external content (facebook/ gravatar/ google adds, etc.) and redirects in general tends to slow sites down.

    http://codex.wordpress.org/WordPress_Optimizatio

    a2hostingrj

    (@a2hostingrj)

    Loaded the site. No issues so far. However, you could reduce the resolution of the images and speed up your site.

    Thread Starter agm285

    (@agm285)

    Thanks. That’s interesting. Maybe it’s only slow to respond after no one has made any requests in a while. Or put another way, maybe it’s the server caching something. Maybe the database isn’t indexed well — or at all. Or a db connection is taking a long time to be generated. Hmm.

    I’ll be curious to read a few more user experiences. Many thanks to those who take the time to clock in.

    Thread Starter agm285

    (@agm285)

    Thanks. Lots of good ideas there. Interestingly, I thought of trying CloudFlare to solve the problem.

    But again, the site is not generally slow — it’s only the first view after a certain amount of time. Don’t have a time limit nailed down yet. And that may mean time with no requests at all or per user.

    So it may be a plugin — I’ll test — but I don’t think so. Some weird server issue. And again, clearing the browser image cache makes for a 3-second load time. Not 30 seconds.

    nocturnae

    (@nocturnae)

    Your site does seem to have really bad performance:

    https://gtmetrix.com/reports/alps-tours.com/xhoE2Tj1

    These are the main ‘damage’ points & actions that can be taken:

    – enable gzip compression (http://softstribe.com/wordpress/enable-gzip-compression-in-wordpress/)
    – Minify javascript ( https://www.elegantthemes.com/blog/tips-tricks/how-to-minify-your-websites-css-html-javascript)
    – Minify css (see above)
    – resize your images (or use a plugin to ‘smush’ them.), seems to cause a lot of waiting time

    If you change the gzip that should make a pretty noticeable difference already.

    Hope this helps!

    I can see exactly the same problem as the one you are describing. If I do not access the site for a couple of hours, the initial access is about 20 seconds. All following accesses is below 2 seconds.

    I suspect either database accesses or (security) plugins which makes expensive calls to external web sites. To address the problem, I have initially switched security plugin (which i believe decrease the delay to load the page no matter what). I also installed a cache plugin. In my case, I have a static front page. So I don’t expect any heavy database access for the initial page. I also have some doubts about a statistics plugin I am using, but I keep it for now.

    When it comes to the server side caching, my host runs the Varnish Cache on the HTTP server. I believe it will work well together with the WordPress cache plugin.

    I’ll wait and see if my updates improves the access time.

    Thread Starter agm285

    (@agm285)

    Our site (alps-tours.com) benefitted quite a bit by having the host move us from a Windows server to Unix/Linux. I had not realized it was on Windows! Now I’m seeing about 6 seconds for initial page, and 3 or 4 seconds on subsequent pages viewed for the first time. Viewing a page a second time is almost instant, which I think is due to the caching plugin we added before the switch to unix.

    But I’ve experienced this first-page-delay problem on other sites as well–including a bare-bones “Hello, World” single page test site, on Unix server, using Twenty-xxxteen, and no plugins. Can’t explain it. So even though my current site is much improved, I’m not satisfied that the larger issue is understood or resolved.

    I have exactly this problem, and it’s very frustrating. Initial loading of the site can blow out to as much as 30 seconds! Subsequent pages are pretty quick to load, averaging maybe 2 seconds. But if I haven’t been back for a while (I haven’t quantified ‘a while’ yet), it’s back to being very slow that for that first page load. The site is new, small, and is using only a small handful of reputable plug-ins. Pingdom did report that there’s an initial wait for the server of up to 20 seconds, so it could be a hosting issue, but then I’d expect that subsequent page loads would suffer too.

    Here’s the URL: https://www.klp.com.au/

    I’m getting a bit desperate, as I’ve already followed all the usual performance optimisation advice!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Initial page slow to load’ is closed to new replies.