Support » Plugin: Duplicator - WordPress Migration Plugin » INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.

  • Resolved ivangil

    (@ivangil)


    I am running PHP Compatibility Checker plugin to make sure that I can upgrade to PHP 7.2 and I am getting the following warnings:

    FILE: /home/howtohea/public_html/wp-content/plugins/duplicator/classes/class.server.php
    ————————————————————————————————-
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    ————————————————————————————————-
    35 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    36 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ————————————————————————————————-

    FILE: /home/howtohea/public_html/wp-content/plugins/duplicator/views/tools/diagnostics/inc.settings.php
    ——————————————————————————————————-
    FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 2 LINES
    ——————————————————————————————————-
    119 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    119 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    120 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    120 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ——————————————————————————————————-

    FILE: /home/howtohea/public_html/wp-content/plugins/duplicator/installer/build/classes/class.server.php
    ——————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————-
    45 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ——————————————————————————————————-

    What should I do about it?
    Can I safely upgrade to PHP 7.2? I really need it because my website is too slow and that is one of SiteGround recommendations.

    Any help would be greatly appreciated.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.’ is closed to new replies.