Support » Plugin: Kadence Blocks – Gutenberg Page Builder Toolkit » Info box breaks – invalid content.

  • I added a kadence Info Box, added content and saved it as a re-usable block. I then duplicated it and converted to a regular block in order to change the content. When I saved the page, WordPress displayed a warning and offered to Resolve or convert to HTML. Choosing both options did not work.

    In the html I noticed unexpected <a> tags in the wrong place and it also highlighted the <br/> tag as incorrect. I think the block does not like it if you try to insert a soft return <br/> between words in the title. It also gets confused if you use the standard WordPress way of adding a link to the Learn More text area of the info block.

    I have re-built the info blocks four times and have finally got it to save, however, I am worried it could break at any time. Is there a way you can make it more resilient and able to use the standard WordPress way of adding links. It is not reasonable to have to teach end users a different way of dealing with specific blocks. It should be consistent.

    • This topic was modified 4 months, 2 weeks ago by mwcs.
    • This topic was modified 4 months, 2 weeks ago by mwcs.
    • This topic was modified 4 months, 2 weeks ago by mwcs.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Hey,
    Thanks for writing, I can see how that would be confusing.

    Links can’t be added inside links else that can break the html. In your info box settings at the top of the list, you have link options. If you have “Link Content” set to the entire box that means the whole box is already a link, adding another link would be inconsistent and not make sense in terms of the markup. Think of it like one big button. If you set it to just the lear more area then still adding another link inside the learn more area would double your links.

    I’m going to remove the option to add links through the toolbar to prevent this confusion.

    Thanks again!


Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.