Support » Plugin: WP Security Audit Log » Infinite Scroll bug when browser viewport taller than log contents

  • Resolved tmuka

    (@tmuka)


    I know I can switch back to paginated view, but it’s worth reporting that with my 4k monitor when the viewport is taller than the Audit Log content rows the infinite scroll throbber image continuously animates, but never loads any more content. There are no scrollbars since my browser is taller than the page content… The javascript probably just needs to check the viewport height and load more entries initially on first load to fix the issue.

    Hope this helps!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor robertabela

    (@robert681)

    Thank you for pointing this out @tmuka

    We will be releasing a plugin update tomorrow or Friday in which we included several infinite scroll fixes. We’ll check this as well and will include a fix.

    Should you notice anything else, please do not hesitate to contact us.

    tmuka

    (@tmuka)

    thanks!

    Plugin Contributor robertabela

    (@robert681)

    Hello @tmuka

    We have just released version 3.4.1 which includes the fix. Can you please confirm if the fix is working for you?

    Thanks.

    3.4.1 is better in that the loading throbber never appears, but still no more entries ever load than the default 25. I can get it to scroll/load more entries only by making my window shorter than the log rows so i get a scrollbar.

    To reproduce in Chrome Dev tools, you can set device emulation to “Responsive” 1280×2250, Desktop. Interestingly, if i set the emulation to my actual viewport height 2160px in dev tools it doesn’t recreate the issue. I’m not sure why it’s different in emulation than with my actual browser (perhaps something with DPI scaling in emulation- windows 10 is set to 100% scaling for me).

    Tell accounting you probably need to get a 40″ 4k monitor for testing! 😀

    Hope this helps!

    • This reply was modified 5 months, 4 weeks ago by  tmuka.
    Plugin Contributor robertabela

    (@robert681)

    Sorry to hear there are still issues @tmuka

    We are looking into this. I wish I could justify needing a 40″ 4K monitor 🙂

    Plugin Contributor robertabela

    (@robert681)

    Hello @tmuka

    The problem seems to be caused by the default number of events that are shown in the audit log viewer.

    So we have added a new filter which you can use to increase the default number and fix the issue. So to fix this please:

    1) Download this path: https://www.wpsecurityauditlog.com/downloads/support/AuditLogListView.zip

    2) Extract the file and copy it, replacing the old file to: /wp-content/plugins/wp-security-audit-log/classes/

    3) Here is an example filter:

    function wsal_increase_infinite_scroll_events() {
        return 50;
    }
    add_filter( 'wsal_infinite_scroll_events', 'wsal_increase_infinite_scroll_events' );

    By the way, are you a developer or do you need help with the filter?

    Looking forward to hearing from you.

    Hi Robert.

    Thanks- Yes, i’m a dev. That patched file and filter do fix the issue.

    Only thing is i’m not likely to implement the filter across dozens of sites. It’s not that big a deal since i know how to work around it by making my browser window shorter…

    If the plugin instead had an option to set default num to view that I could update with wp-cli i’d be more inclined to use it.

    Thanks for caring enough to make the fix available! I appreciate your hard work on the plugin.

    Thanks!

    Plugin Contributor robertabela

    (@robert681)

    Glad that solved the issue @tmuka

    In the next version we will include this as a setting in the plugin so then you can easily export/import the base plugin configuration if you want.

    At the moment we do not have CLI support but it is something we are considering and should be able to add in the near future since it helps automation.

    Should you need any further assistance please do not hesitate to ask. May I ask you to please spare a minute and rate our plugin and service? We really appreciate these reviews.

    Thank you very much and have a great day.

    Excellent, thanks! Rated! 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.