Support » Theme: Flato » Infinite loop when running a webpage

  • When running a simple WordPress webpage there seems to be a JavaScript loop that won’t stop running, and I believe it’s affecting memory usage on the browser. I disabled the plugins I had in case of a conflict.

    Error message
    	TypeError: image.complete is undefined
    	if (image.complete || image.readyState == 'complete' || image.readyState == 4) 
    
    Error location:
    	/flato/js/scripts.js?ver=4.2.3
    	Line 73

    For reference: http://hitorclickmarketing.com/test/

    Thanks for any help!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    You disabled the plugins and then you faced an error message?

    Hi Andrew,
    No, the error is persistent with or without them. I only see the error in the development console log, which I would ignore but it’s eating memory. The error is not present when another theme is active.

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Let’s see a page with the issue

    http://hitorclickmarketing.com/test/
    check the browser’s console log

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Are you sure that’s the right page? First clear your error log and refresh, do you still get that error?

    Oh, pardon me! I disabled the theme to test and forgot about it. Please try it now.

    The error is not present without the theme. I just cleared my browser data and restarted my browser and it’s still there.

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Can you add an image into the slider for now to resolve this?

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    @theme authors, You should check if elements exist before you target them with plugins 😉

    I’m not even aware of a way to set up a slider through this theme, so I just removed the function. The page still isn’t able to finish loading according to Chrome, but at least the error isn’t there.

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Yeah, not good, there’s setTimeouts all over the place :s

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Until the author has enough time to improve the JS of this theme, or someone else can (big ask), you might want to try a better one 😉

    How do you view setTimeouts? I don’t see that in Chrome developer tools or Firefox’s FireBug.

    I installed it here while testing the issue: http://hitorclickmarketing.com/waypoint/

    Do you see the same errors? For some reason it seems to work after removing the function. I just wanted this theme to be a quick fix :p

    Moderator Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Don’t do it, it’s already done in the theme and that’s the thing that’s causing the infinite loops. It’s how not to do things. I did see the same errors that you pointed out.

    Do you see the same errors? For some reason it seems to work after removing the function.

    You removed the code that was causing the issue for that example. So it fixed it.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Infinite loop when running a webpage’ is closed to new replies.