• Resolved WebsThatRock


    I use the types and views plugin and received a problem having the page load and this is what the hosting company tech support has found. Does anyone have any idea on how to fix this?


    Unfortunately, it appears that the “Types” plugin is malfunctioning. I was able to trace the PHP process running, and with the Types module installed your WordPress blog was stuck in an infinite loop, constantly calling the exact same SQL queries over and over and over again and never completing generating the page, which is where you were getting the 500 errors.

    (Query for example: SELECT * FROM wp_frm_display WHERE insert_loc != ‘none’ and post_id=6928 LIMIT 1 and SELECT * FROM wp_posts WHERE ID = 5639 LIMIT 1 are two queries I see endlessly repeated until PHP and WordPress die.)

    By disabling the “Types” module I was able to get the pages to load, but because this one page really depends on the types module you now see the Types shortcodes instead of content, and clicking on the links take you to 404 pages.

    My apologies, but we won’t be able to assist any farther with this, as it appears to be a coding or configuration issue with the Types plugin. You’ll need to contact the developer of Types for further support. It’s possible that Types is interfering with another plugin you have installed or that there’s some configuration issue involved here, but configuring WordPress modules is outside the scope of our support.

    If you have any further questions or concerns, please let us know.


    Zoe B.
    Linux Systems Administrator II


Viewing 5 replies - 1 through 5 (of 5 total)
  • The website that is enacted with the Types plugin is http://alabama.ustrails.net. Like I mentioned the Types plugin has been deactivated. When trying to load the trails page seems to load forever then finally stops with a 500 internal server error. I have Types version 1.0.4 and Views version 1.1.2.

    I tried deactivating the views plugin and keeping the types plugin activated then viewed the page where a trail is on at http://www.alabama.ustrails.net/archives/trail/alabama-scenic-river-trail-11 and it loads up with the shortcodes. I went to this page directly because I couldn’t go through the navigation to get to it with this plugin disabled.

    I then tried deactivating the types plugin and keeping the views plugin activated then viewed the page where a trail is on at http://www.alabama.ustrails.net/archives/6912/alabama-scenic-river-trail-2 and it redirects me to a page not found error. (I had to go to this page by going to Trail List>Alabama Scenic River Trail.)

    Dear User,

    There must be a conflict with another plugin, because the table you mention in the SQL statement (wp_frm_display) is not related to WordPress or Types and Views. I googled the table name and it seems to belong to Formidable, try disabling that plugin to confirm.


    Yes, it was with another plugin called Supra CSV that was causing the problem. It was providing a description and I also was using Views and Types to provide a description. I solved the problem by leaving the field blank on one plugin.

    Thanks for clarifying.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Infinite Loop Problem’ is closed to new replies.