Support » Plugin: RPS Include Content » Infinite loop problem

  • Resolved rl7greg


    Hi, tried adding a text widget to my homepage with:
    [rps-include post=1400]

    And instead of the post content being displayed, I get a red box containing:
    An infinite content loop detected involving the following:
    (my site name) ยป Front Page Content (this post)

    Any ideas?

    Post 1400 is just a simple post, with a h3 header and some text. Nothing fancy.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author redpixelstudios


    RPS Include Content adds the requesting post (in this case your home page) to an array that is used to test for infinite loops. If post 1400 does not have an include that references the home page (or any other page for that matter), the error state should not be triggered.

    We tested the plugin by adding the shortcode to a text widget just as you did, but were unable to reproduce the problem. Of course our sandbox testing environment (WordPress 3.4.2, Twenty Eleven theme, RPS Include Content 1.0.9) is likely different from your specific installation so there are many variables that were not considered.

    Would it be possible for you to enable another comparable theme? If the problem continued then we would suggest narrowing down the issue by disabling plugins until you identify the conflict. That would give us the information that we need to go on to troubleshoot the problem further. Thanks for your efforts and keep us posted.

    I am using this theme:,97.html

    I tried to enable the 2011 standard theme, and had to move the widget to another area to check, but then it did display properly. I am pretty much tied in to using the theme I am using though, so I will have to check with the theme developer.

    Here’s the page though that I am trying to include on the homepage, if that might give you any clues to the problem with my theme:

    Plugin Author redpixelstudios


    We went ahead and downloaded and installed the theme MeetGavernWP to do some testing. Fortunately we did not run into any errors, and the included page displayed normally no matter which sidebar the Text widget was placed into.

    It would seem that the content you are trying to include on the home page can be placed there without the use of a widget, as it likely doesn’t need to appear on any other pages. If that is the case, you could just add the shortcode to the content area of the home page. We tested that solution and it worked as well.

    If this is not what you were trying to accomplish, could you share the exact procedure that you are using so that we can see if the issue can be reproduced? A step-by-step would be very helpful. Thanks in advance.

    I created a text widget with no title, just the content:
    [rps-include post=1400]
    …in the Mainbody location, and set it to display on no pages excepting Homepage.

    My purpose to do it this way, was to allow someone with less privileges in wordpress to edit that text whenever needed.

    In the template settings under Template options -> Basic I have:
    Widgets display on homepage – enabled
    for Template options -> advanced I have
    Widget rules – enabled

    Not sure if those were the defaults for the theme. I’m also using a SVN version of the theme, not quite up to date….sorry for the hard to duplicate scenario.

    I just updated to the latest SVN of gavern, and removed all the other widgets from my homepage temporarily, and tried it again, in the mainbody-bottom section – to display on no pages excepting the homepage and this page:

    …and it displays on the bottom of that page, but still got the infinite loop error message (when logged in, blank space when not logged in) on the homepage

    Living dangerously….I removed the whole section:

    if ( in_array( $blog . ‘,’ . $post, self::$included ) )

    from rps-include-content.php

    And it works on the homepage now, in any section. I’m happy to help test any other code you might want to try in place of that, but I was just planning to use it for this one page/situation, so the problem is fixed for me. Did it really work for you on the homepage with the gavern theme enabled? If so, I am still baffled as to the reason why.

    Plugin Author redpixelstudios


    It seems that the Widgets display on homepage was disabled by default and the Widget rules were enabled by default.

    We can probably setup an option to disable the loop checking so that you (and anyone else experiencing this issue) can avoid having to modify the plugin source. Hopefully we can figure out the cause and adjust the loop checking to work.

    The include did work with the theme so it is likely that there is some difference in our configuration that allowed us to avoid the error.

    Just a couple more pieces of information are needed:

    1. What is your Front page displays setting under Settings > Reading?
    2. Is the post_type of the include a post or a page?

    Thanks for sticking with us to resolve the issue.

    1. Set to ‘Tour Latest Posts’ – but I the GavernWP settings seem to override that?
    2. The include (id# 1400) is a post, not a page

    Plugin Author redpixelstudios


    The configuration is now as close to yours as we can get it and the problem doesn’t show up. The cause must be some variable that we are missing here. It could be MeetGavernWP settings or installed plugins. Our guess is that another plugin could be causing a conflict. The only way to tell for sure is to restore the code that you removed from RPS Include Content, then disable all plugins except ours. If the problem persists then there is no issue with the other plugins and we can go from there.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Infinite loop problem’ is closed to new replies.