Support » Plugin: Add-on Contact Form 7 - MailPoet 3 » Infinite loading when sending the form

  • Resolved collaborato

    (@collaborato)


    Hello,

    When sending a cf7-form I get an infinite scroll. It happens every time I insert the code

    [mailpoetsignup newsletterbestellen list:3 “Ich will quartalsweise informiert werden und bestelle den WordPress Newsletter (optional)”]

    As soon as I remove the code – the form works. All Plugins, Themes and WordPress are updated to the latest Version.

    Chrome Console gives me a “Error 500”:

    POST https://collaborato.de/wp-json/contact-form-7/v1/contact-forms/5232/feedback 500
    send @ jquery.js?ver=1.12.4-wp:4
    ajax @ jquery.js?ver=1.12.4-wp:4
    wpcf7.submit @ autoptimize_ae5827d69a46b9ef42d83239599d350d.js:22
    (anonymous) @ autoptimize_ae5827d69a46b9ef42d83239599d350d.js:9
    dispatch @ jquery.js?ver=1.12.4-wp:3
    r.handle @ jquery.js?ver=1.12.4-wp:3

    Greetings,

    G√ľnther

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Could be due to Autoptimize: as a quick test you can disable AO on a per-request basis by adding ?ao_noptimize=1 to the URL.

    If your site works that way, then disable JS optimization for a second to see if that fixes it. If so, then you’ll probably have to add the plugin’s JS to the comma-separated JS optimization exclusion list. In that process you should keep an eye on your browser’s console for JS errors, as those will help you identify the problem.

    AO’s FAQ has more info on troubleshooting and how to exclude.

    hope this helps,
    frank (ao dev)

    I have deactvated the autoptimize plugin now. Deleted the cache. Does not help.

    Hello, thanks for reporting. This issue is caused by major changes of MailPoet plugin (v3.39.1). We will fix that issue in our next plugin update.

    Thanks

    Aiximmo

    (@aiximmo)

    Hi
    I have The same Problem on MY site.

    Kamrul@Tikweb

    (@abdultikweb)

    Please update the plugin. It has been fixed in the newer version of the plugin.

    Thanks

    collaborato

    (@collaborato)

    Works! Great! Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.