Support » Plugin: Add-on Contact Form 7 - MailPoet 3 » Infinite loading when sending the form

  • Resolved Peter Smits

    (@psmits1567)


    Hi

    This problem has occurred after updating mailpoet 3.39.1 to 3.39.2
    Then the plugin was updated issue resolved
    But with the latest mailpoet update to 3.40.0 it is back again !
    No errors in the debug file.
    Please have a look at it again
    I could not find the previous post, so I added this new one

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello, in our side, the plugin is working as expected with MailPoet version 3.40.0. We also tried in different WordPress installation. No infinite loading issue. Could be plugin/custom theme confliction or other issues in your side. Please disable all other plugins and try again. Also, please check in different WordPress installation.

    Thanks

    Hi checked it on a different installation where it did work indead.
    Went back to the installation not working and checked the SMTP settings
    Sending a testmail from this plugin did not work.
    The problem was the setting for authentication, it was set to “TLS”
    With that setting I tested it before and it worked.
    But now it did not work anymore, so I altered it to “SSL”, and did succesfully sent a testmail. So after that tested the contactform add on, and it did work again.
    So the problem is resolved, however an improvement could be made here!
    Because in the SMTP plugin an error came back with the wrong setting.
    That does not happen when using the add-on mailpoet plugin.
    So it seems to me that the handling of errors from mail sending are not handled properly. It should not stay in the loop, but break out of it, in case there is returned an erro or it takes to long.
    Hope this will help you improving the plugin
    Thanks for your quick support !!

    Hello, glad that you found a workaround. Thank you for the information. It will help us to improve the plugin in the future.

    Thanks

    Hi

    Again on two different sites I have the problem with infinite loading!!
    I can sent a test email from within mailpoet, and the lowlevel SMTP plugin.
    What can I do to debug this problem, and help you sort it.
    It appears to me that the program does not see/get the answer from the SMTP plugin or MailPoet that the email address has been added.
    No errors can be found in the debug.log

    The following versions are running
    Add-on Contact Form 7 – Mailpoet 3 V 1.3.13
    Mailpoet V 3.40.0
    WP Mail SMTP 1.7.1
    Regards,
    Peter

    Hi

    I now know what caused the issue, so I can reproduce it.
    Could you point me to the routine that sends/ appends the details to mailpoet.
    I can give you more detailed info if I know where to look.
    It was caused by a setting in a security plugin called “WP security”.
    The setting is called WP REST API, so I assume this influences the API you are using to sent the data to Mailpoet. The setting does not allow unauthorised REST requests if set.

    Regards,
    Peter

    Hello,

    We are using the MailPoet’s official API. You can find the details here: https://github.com/mailpoet/mailpoet/tree/master/doc

    Thank you

    Hi Kamrul

    I have tested the problem with the setting I indicated.
    It appears that if I set the setting for blocking non authorised API requests, the API of mailpoet does not get an answer when adding a subscriber or is not called.
    Within the plugin All in one security, there is a warning about setting this.
    So the problem is not within your plugin, but within this security plugin.
    That does not seem to answer properly when this request is done.
    I will contact the developer of this plugin to ask him what should happen.
    I will let you know the answer

    Hello, Peter

    Thanks for your effort 🙂 Please let us know if you found the issue.

    Thank you

    Hi Kamrul,

    I found the reason for this issue 🙂
    Within the security plugin this routine is called

    function check_rest_api_requests($rest_server_object){
    $rest_user = wp_get_current_user();
    if(empty($rest_user->ID)){
    $error_message = apply_filters(‘aiowps_rest_api_error_message’, __(‘You are not authorized to perform this action.’, ‘disable-wp-rest-api’));
    wp_die($error_message);
    }

    So the security plugin does not answer the call but dies 🙁
    I have made a remark to the plugin developer about this.
    But I also would like to propose an improvement if possible in your plugin.
    1. Create a time-out value for waiting on an answer.
    2. In the call to the API use this time-out, so the program stops waiting.

    You still do not know what is happening, but you can present a warning to the subscriber. This should indicate to warn the administrator that the subscription did not work.
    Thanks for your help

    Hello,

    Thank you for your suggestion. We will look into it

    Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Infinite loading when sending the form’ is closed to new replies.