Support » Theme: Neve » Infinit Scroll not loading more than 10 items on CPT archive page

  • Hello,

    I made a child theme of your wonderful Neve theme.
    With PODs, I’ve created the CTP “Project”.
    The archive page is the original one. All the changes are through css.
    When in Appearance > Customizing > Layout > Blog/Archive > Post Pagination, I choose “Infinite Scroll”, no more than 10 items are shown and the loading icon is spinning endlessly underneath them.

    Thank you for helping me!

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi @quasidigi,

    Just to confirm – are there more projects created now than those 10 that are visible? Does it work if you switch to pagination?

    I’ve noticed that you have some custom javascript code and it constantly console.logs to the console – could you remove that code to verify there is no conflict? (not only the logging but temporary remove all the custom code): https://ibb.co/3F1vWn2

    Let us know if that makes the infinite scroll work as expected, thank you!

    Hi @bvytis

    At the moment. there are a total of 11 projects created. Projects that I can see when I switch to pagination. Do you wish me to switch to pagination? You can, from the last project of the list (link to last project in the list), navigate to the last one (very last (invisible) project).

    I have removed my custom script from the wp_enqueue_scripts list. There should be only the custom styles. To test, I’ve also removed the custom css and commented the custom functions.php (at the moments it’s only enqueueing styles and script, and handling some error message).

    The problem persists. So, I enabled again the styles and functions.php.

    Thank you!

    Edit: After updating wp to v5.5 and all installed plugins to their latest versions, I have tried to disable all plugins EXCEPT pods. Pods can not be disabled because it is creating the project custom post type. Unfornutally, it didn’t help.

    • This reply was modified 3 months, 2 weeks ago by quasiDigi. Reason: added info
    Vytis

    (@bvytis)

    @quasidigi I see that https://ostrehrany.com/wp-json/nv/v1/posts/page/2 endpoint doesn’t give results – please try to re-save permalinks in Settings->Permalinks section to check whether “refreshing” permalinks solves this issue.

    Let us know if that helps, thank you!

    quasiDigi

    (@quasidigi)

    hi @bvytis,

    Thank you for coming back to me.
    I have tried several times (also tried to change the permalink structure) without success.

    Bear in mind that I am showing a Custom Post Type archive page. The wp endpoint would be https://ostrehrany.com/wp-json/wp/v2/project?page=2

    Thank you!

    • This reply was modified 3 months ago by quasiDigi. Reason: typo
    quasiDigi

    (@quasidigi)

    hi @bvytis,

    In the end, I did the CTP manually in the child-theme. The issue is still there, although I had to place the archive page to pagination because the site is live atm.

    The wp REST API endpoint https://ostrehrany.com/wp-json/wp/v2/project?page=2 is still valid.

    Thank you

    • This reply was modified 3 months ago by quasiDigi. Reason: small edit

    Hello, is there any update on this issue?

    I have updated to all latest versions and tested it by deactivating all plugins.

    AC

    (@purplecodes)

    Themeisle Support

    Hi @quasidigi,

    Apologies for the late reply.

    I checked your site and saw 11 projects now
    https://snipboard.io/pQCP1k.jpg

    Let us know if this is still an issue.

    Hi @purplecodes

    Indeed, you see all 11 projects because I made a custom home page in PHP. This home page is not using the infinite scroll but loads all projects at once. I had to do this because the site is already live. Sadly this is a temporary solution because soon there will be more than the double amount of projects.

    Here is the link to the category page with the infinite scroll: https://ostrehrany.com/projekty/

    Thank you for your time

    Hi @quasidigi,

    Could you please check if functionality works with default posts and the issue is only when using custom posts types or infinite scroll does not work at all on your instance?

    Thank you for working on this!

    quasiDigi

    (@quasidigi)

    Hi @bvytis

    I’ve created 13 extra blog posts and they all show up, but the loader does not disappear. You think it’s the issue is on how I made the CPTs?

    https://ostrehrany.com/blog/

    Hi @quasidigi,

    I think the loader does not disappear because of how posts are created and because they are taking so little space. Try to add text or featured images and it should load as expected, 10 items at first and other on the scroll. If you would make the browser screen much smaller in height you would notice that scroll disappears after the remaining items are loaded.

    Yes, I assume this is related to custom posts types that you created if functionality works as expected with default posts.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.