Support » Plugin: Duplicator - WordPress Migration Plugin » Inexplicable stylesheet issue

  • Hi Cory! Love your Duplicator plugin and have used it several times with great success. But I’m now getting the strangest thing. I duplicated my client’s site over to a staging site for best-practices testing of updates etc. And the staging site “mostly” displays well, but is somewhat wonky in its layout and css. So I view the site in Safari with the Web Inspector, and eventually discover that… if I change the URL for the site’s stylesheet…

    <link rel=”stylesheet” id=”vjff-css” href=”http://staging.vjff.org/wordpress/wp-content/themes/VJFF/style.css” type=”text/css” media=”all”>

    …by taking out the “staging.” from the URL, so it reads:

    <link rel=”stylesheet” id=”vjff-css” href=”http://vjff.org/wordpress/wp-content/themes/VJFF/style.css?ver=2.1.2″ type=”text/css” media=”all”>

    …the site displays perfectly.

    The only differences were the expected ones, i.e. links to images in the staging site point to graphics there, not the live site (similar difference to the change I made above).

    Weirder still, if I manually edit my staging site’s CSS file to have the exact same content as the live site, I STILL get the wonky site display, which STILL resolves if I change the stylesheet’s URL in Web Inspector.

    I’m just baffled by this one and – though I realize it’s probably not strictly a Duplicator issue – I don’t know where to turn. So I’m hoping you can suggest something…. let me know.

    Thanks!
    Adam

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @cosmocanuck,

    A few things you might try:

    1. Browse directly to http://staging.vjff.org/wordpress/wp-content/themes/VJFF/style.css and make sure you can see it

    2. The staging site is missing the css query string ver=2.1.2

    3. Clear your browser cache and temporarily disable any cache plugins you may have enabled.

    Let me know if that helps!

    Hey Cory! Thanks for getting back to me. It was a pretty baffling situation, but after I did the same upgrades to various plugins on the live site as on the staging, assuming the display trouble was just to to with the staging site, I found I was wrong – I got the same problem there!

    So I’m quite sure it’s really to do with one of the updates and unrelated to Duplicator.

    I should mention though, that Duplicator saved my butt! When I accidentally introduced the same mystery glitch into the live site, I was pretty worried – then I remembered that I had a working, pre-update Duplicator package. So I reinstalled it on the staging site – and confirmed that it then worked again – then I transferred THAT back to the live site.

    So, no problems whatsoever with Duplicator and indeed it was the hero here. Thanks! 8^)

    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks much!

    I did notice browsing out to:
    http://staging.vjff.org/wordpress/wp-content/themes/VJFF/style.css

    I get a 404, so that file is missing from the system…

    Hope you can get to the root issues…

    Cheers~

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Inexplicable stylesheet issue’ is closed to new replies.