Support » Plugin: Advanced Custom Fields: Extended » Individual subfields not working on forms

  • Resolved Tristan

    (@tristanmsg)


    I have a form with an address field containing multiple Text subfields (line_1, line_2, town, etc.), and I want to render these in multiple responsive columns rather than the default single column layout.

    When I specify individual subfields in ‘HTML Form render’, if I mention them by name (e.g. {field:line_1}), they do not render at all, and if I mention them by key (e.g. {field:field_625b7f82643f7}), they do render, but their values do not get loaded or saved, even when the parent field address is selected in Post Action under the Load and Save tabs.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello,

    Thanks for the feedback!

    Unfortunately it is not possible to display Sub Fields individually when using the Custom Form Render setting, due to ACF core limitation.

    ACF Sub fields (from a Group, Repeater, Flexible Content etc…), must be rendered within their respective parent, with their bultin HTML, otherwise as you pointed out, you may experience unexpected behavior.

    In your case, a workaround could be to use the Repeater “Layout: Block” setting in combination with the ACFE Column field in order to display sub fields within columns. With some extra CSS, you should be able to get the render you’re looking for.

    Hope it helps!

    Have a nice day!

    Regards.

    Thread Starter Tristan

    (@tristanmsg)

    I was not aware of the Column field – that helps a lot!

    Thanks!

    Plugin Author Konrad Chmielewski

    (@hwk-fr)

    You’re welcome!

    Regards.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.