Support » Plugin: Participants Database » Individual Record not showing

  • Resolved reunited2017

    (@reunited2017)


    I appear to have lost the link from the Database List to the Individual Record.
    It worked previously so am a bit confused.

    I have the [pbd_single] on the Individual Record page and List display setting to that page. Any idea why there would be no data once this link is opened?

    Thanks in advance for all suggestions.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author xnau webdesign

    (@xnau)

    I’m assuming your “Single Record Link” is set up properly, so you are getting your links in the list. Those URLS should all have something like ?pdb=234 at the end (unless your using the pretty permalinks add-on).

    If that is the case, then something has changed on your single record page. Take a look at the page content using text mode, make sure the shortcode is correct, that there are no spaces in [pdb_single and that if you have other attributes in your shortcode that has to be a space after [pdb_single

    Of course there has to be a close bracket too, but the first part of the shortcode has to be correct or it won’t work.

    Sorry, I am having the same trouble. I have a page for the list and another page for the detail. I always add codes using the “Text” setting. You can click on the linked name and the ?pdb=234 is being passed and it goes to the page okay but nothing displays after than.

    This is the only thing I have on the page:

    “Complete Details of the Park and it’s workamping information

    [pdb_single]”

    I don’t have any other plug-ins activated as it is a new site. I changed the PHP version to 7.0. http://workamping-in-florida.websandblogsforwriters.com is the website if you want to look. Thanks for any suggestions.

    Plugin Author xnau webdesign

    (@xnau)

    I’m not seeing this problem with php 7.2 (not able to test 7.0). Clearly, the shortcode is working, but something is stopping the template from displaying. Do you have your php error log set up? Probably there will be something there to help understand the problem.

    Thread Starter reunited2017

    (@reunited2017)

    Hi
    It all appears to be set up ok. When I click on a record I get this in the bar
    http://reunited.ie/individuals_record/?pdb=2
    it looks like it is missing the word details. If this is the problem can you advise how I fix it and more importantly how would it have changed?

    Many thanks

    Okay I updated the PHP to 7.2 and even tried a couple different themes but still not record display on the ParkView page. I have enabled DEBUG and now shows the following errors on the page itself:

    “Notice: Undefined variable: field_count in /homepages/40/d601343514/htdocs/clickandbuilds/WorkampinginFlorida/wp-content/plugins/participants-database/classes/PDb_Shortcode.class.php on line 684

    Notice: Undefined variable: all_empty_fields in /homepages/40/d601343514/htdocs/clickandbuilds/WorkampinginFlorida/wp-content/plugins/participants-database/classes/PDb_Shortcode.class.php on line 687”

    and the PHP Error Log has the following:

    “[01-Feb-2018 12:35:36 America/New_York] PDb_List::_setup_iteration list query: SELECT p.id, p.district_no, p.park_name, p.address, p.city, p.state, p.zip, p.website, p.type_of_park FROM OmJHFgzRparticipants_database p ORDER BY p.park_name ASC

    [01-Feb-2018 12:35:41 America/New_York] PHP Notice: Undefined variable: field_count in /homepages/40/d601343514/htdocs/clickandbuilds/WorkampinginFlorida/wp-content/plugins/participants-database/classes/PDb_Shortcode.class.php on line 684

    [01-Feb-2018 12:35:41 America/New_York] PHP Notice: Undefined variable: all_empty_fields in /homepages/40/d601343514/htdocs/clickandbuilds/WorkampinginFlorida/wp-content/plugins/participants-database/classes/PDb_Shortcode.class.php on line 687

    Log file: /homepages/40/d601343514/htdocs/clickandbuilds/WorkampinginFlorida/php-errors.log (728 bytes) ”

    I’m not sure what this means, any help would be greatly appreciated.

    Plugin Author xnau webdesign

    (@xnau)

    It’s possible you’re both facing the same issue: it looks like you do not have any fields that are configured to show. Check your field groups, make sure that the groups you want visible have “public” checked.

    You are the man! That was a simple fix and I feel stupid not to try that. Thanks

    Thread Starter reunited2017

    (@reunited2017)

    Me too. I looked and sure enough the person who was trying to help with a problem re incorrect date being displayed had unknowingly unticked this box.

    @xnau, spot on as always, thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Individual Record not showing’ is closed to new replies.