WordPress.org

Forums

Full Screen (Page) Background Image Slideshow
[resolved] Individual Pages are not Overriding the main settings (4 posts)

  1. ddpweb
    Member
    Posted 2 years ago #

    Hello, and thank you for this plugin! Really perfect for the project I'm working on.

    I appear to have found a bug in the plugin however. In the main slideshow settings I have created a slideshow. This works great!

    I have this slideshow set to display on the FrontPage and the Category pages. This works!

    The issue is on the individual pages, the fields for the slideshow do not seem to load the background photo at all. The area where it says:

    Enable custom background image for this page

    I'm loading an image here. It appears to use the image ID rather than the path to the image. Is this correct?

    But when I look at the page, it's not loading the script in the footer at all. Or the image that I want to load.

    Am I missing something here?

    http://wordpress.org/extend/plugins/full-screen-page-background-image-slideshow/

  2. breynolds
    Member
    Posted 2 years ago #

    I started using this plugin on a project about a month ago and ran into this same issue. I had to put that one down for a bit and hoped this would be resolved. Well, there has been no response or update so I dug in and fixed it myself. If you are still having the issue try the following:

    On line 72 of the "full-screen-background-image-slideshow.php" file change "is_singular" to "is_page". The current code is evaluating for a post instead of a page.

    Also, another annoying thing is the "checked()" function in the metabox is currently set to echo back the string which displayed above the check boxes. If you want to remove this as I did then change the following in the "inc/post-metabox.php" file. The changed will be in lines 21 & 22.

    Line 21 - change the last argument from true to false like so:
    checked(get_post_meta($post->ID,'fsi_fs_images',true),'1',true) -> checked(get_post_meta($post->ID,'fsi_fs_images',true),'1',false)

    Line 22 - change the last argument from true to false like so:
    checked(get_post_meta($post->ID,'ffsi_fs_images_slideshow',true),'1',true) -> checked(get_post_meta($post->ID,'fsi_fs_images_slideshow',true),'1',false)

    Aside from these oversights it is a good plugin and I hope the author will keep up with it. Hope this helps.

  3. ddpweb
    Member
    Posted 2 years ago #

    Thanks so much for this post!

    I've made the update to the file, but I'm still finding that the code doesn't get loaded on the page.

    I had done a work-around in the interim, by using the output from the plugin, and just loading it with conditions in the footer for: pages, single, search and error. It works, but I'd prefer to control it from the dashboard.

    So for testing I've removed that static code in the footer, made this update to the plugin file and loaded it, set an image on my page, and then tested. The code doesn't load unless I select the slideshow option for pages in the main settings (but then it just loads the slideshow, which I don't want. I just want a background photo).

    Is that footer code loading for you when you use the 'custom background image' option from the page itself?

    Also, is it supposed to use the image ID in that field, or the path to the image?

    Thanks for any help on this!

  4. Mohsin Rasool
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks breynolds for taking time to fix it. I have included these changes in plugin.

    is it supposed to use the image ID in that field, or the path to the image?

    Both of them would work.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Full Screen (Page) Background Image Slideshow
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic