Support » Plugin: All-in-One Events Calendar » Individual events are blank

Viewing 15 replies - 1 through 15 (of 20 total)
  • Also have this problem. Can’t find page, but show up in calendar view.

    Never mind, had a competing calendar installed – The Events Calendar. Solved.

    • This reply was modified 4 years, 3 months ago by anoleimaging.

    HI @michfm,

    The problem you describe could be a result of a plugin or theme conflict (usually caused by a caching or security plugin).. Please try a different theme temporarily such as Twenty Seventeen, or, disable all plugins and then check if the problem recurrs — then re-enable each one until you find which one caused the problem.

    Let me know if that solves your problem.

    Thread Starter michfm

    (@michfm)

    Hi,

    I’ve changed the theme temporarily and the calendar is working. However, when I try to add or edit events and check the calendar, the events are not displaying. I’ve also disabled plugins but I get the same results.

    I would appreciate your help on the issue.

    Thanks!

    Hi @michfm,

    Here are some solutions that might work, in no particular order, please try each one and let me know if/which one solves your problem:

    – Make sure that your Calendar page is set to the right page in the Settings > Viewing Events tab (no need to use shortcode on a page set as the default in the plugin settings)

    – Try turning on/off “Strict compatibility content filtering” in Events -> Settings –> Viewing Events.

    – Try turning on/off “Use frontend rendering” in Events -> Settings –> Advanced

    – Try resetting permalink settings to Plain, Save Settings, and then back to your custom style, then Save the settings

    Thread Starter michfm

    (@michfm)

    Hi @sunny454,

    Thank you for the options to resolve the issue. However, the issue wasn’t fixed. I would appreciate if you would further investigate on it?

    Thank you very much!

    Hi @michfm,

    Do you have a competing calendar plugin installed and activated?

    If not, make sure that your WordPress and our plugin is up-to-date and that your host is running PHP 5.6 or newer as older versions are depricated and unsupported.

    If the events still don’t appear, you can try a manual reinstall:

    – Perform a complete back up of your database before proceeding further
    – Delete the file uninstall.php from the plugin directory that is currently on the server (found under /wp-content/plugins/all-in-one-event-calendar). Deleting this file ensures that when you uninstall the current version of the plugin, your event data and calendar settings will be preserved when you delete the plugin (don’t skip this step – it’s important!)
    – Deactivate the All-in-One Event Calendar using your WordPress Dashboard.
    – Delete the All-in-One Event Calendar using your WordPress Dashboard.
    – Database -> wp_options, click option_name to sort and delete everything with ai1ec_, this will delete plugin settings but events will remain in the database.
    – Now install the latest version.

    Thread Starter michfm

    (@michfm)

    Thanks for your reply, @sunny45.

    We don’t have any competing calendar plugin installed except that I noticed that there’s a built-in event/calendar from the theme that we are using. I’m not sure if it’s causing the issue.

    We are now also running PHP7.

    Thanks for your help!

    Hi @michfm,

    I apologize, this should have been one of the first steps I should have given:

    This could be a result of a plugin or theme conflict (usually caused by a caching or security plugin).. Please try a different theme temporarily such as Twenty Seventeen, or, disable all plugins and then check if the problem recurrs — then re-enable each one until you find which one caused the problem. Let me know if either of these steps works.

    Thread Starter michfm

    (@michfm)

    Hi, @sunny454!

    I changed the theme of the site and it doesn’t fix the issue. I’ve also disabled and re-enable the plugins but the events do not display in the calendar.

    Thanks for your help!

    Hi @michfm

    Did you try the manual re-install instructions I provided?

    Thread Starter michfm

    (@michfm)

    Hi @sunny454,

    Yes, I re-installed it manually but didn’t fix the issue.

    Thanks for you help!

    Hi @michfm,

    I noticed that there is a different calendar installed on your website using the URL:

    https://www.bbcprospect.com/events/

    Our Core calendar uses the /events/ subdirectory by default to show events.

    Example event:
    https://www.bbcprospect.com/event/ladies-retreat-2/?instance_id=13259

    The event shows up blank — it’s likely due to the incorrect .htaccess settings.

    Can you try this test:

    If the competing calendar is part of your theme, change the theme to a different theme, then go to Appearance > Permalinks >

    Change the Permanlink settings to a different setting, Save Settings.

    Change it back to your desired setting, Save Settings.

    Test if the event page loads now:
    https://www.bbcprospect.com/event/ladies-retreat-2/?instance_id=13259

    Thread Starter michfm

    (@michfm)

    Hi @sunny454,

    The event page loads when I change it to Twentyseventeen theme, but it still doesn’t appear on the calendar itself whether I select agenda, day, month or week view. While on the current theme, it neither displays the event page nor in the calendar.

    I hope you can further look into the issue. Thank you for your help!

    Hi @michfm,

    There’s nothing much more that I can do on my end, as it appears there are conflicts with both, your theme, and 1 or more of your other plugins. Your solution is to switch themes and disable the conflicting plugin(s).

    Alternatively, you can try switching to one of our new hosted Saas Web App calendars which can be embedded with no conflicts at all, and are available from here:

    https://time.ly/pricing/

    Thread Starter michfm

    (@michfm)

    Hi @sunny454,

    Is there a way that we can change the slug for the AIOC events? The theme developer suggested a solution to change the slug for the calendar and individual events. Thank you!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Individual events are blank’ is closed to new replies.