WordPress.org

Forums

[resolved] index.php thrown into the path (13 posts)

  1. Anne-Marie
    Member
    Posted 9 years ago #

    First of all I apologize if I'm posting this in the wrong area.

    We are having a bit of a mystery here.
    I managed to integrate MG2 gallery with WP2 using the WP-Andreas09 theme. This with help ofcourse :)

    Now the mystery : my links (the 1 2 all links) are getting an index.php thrown into the path.

    Here is an example http://www.albums.seacloudies.com/wordpress/gallery/index.php?list=2

    When clicking on one of the links it doesn't show anything or it directs me back to the main index.

    Now my site is a complete clone of this site http://www.chrispayne.ca/wp2/photos/
    a testing blog just set up as an example by Chris Payne who helped me out.
    As you can see his links are working just fine and mine refuse to work. Chris send me the php files, and the only thing I've changed is the url and directories path.
    You would say it should work nah? Nope...

    Any ideas?

    TIA

  2. Anne-Marie
    Member
    Posted 9 years ago #

    Please anybody??

  3. Chris_K
    Member
    Posted 9 years ago #

    Have you turned on Permalinks?

    Log in as Admin and go to Options -> Permalinks

  4. Anne-Marie
    Member
    Posted 9 years ago #

    They are set to default..but I've tried all the option available here with no results.

  5. Chris_K
    Member
    Posted 9 years ago #

    After changing them to anything besides default, do you get a message about the .htaccess file update?

    Does your blog directory have an .htaccess?

  6. Anne-Marie
    Member
    Posted 9 years ago #

    This is what I get :If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    As far as I can see I can't find a .htaccess file..I presume this should be in my wordpress folder? (even so I've looked all over the place no such file)
    If this file is missing should I create one and if yes how do I do this?

  7. Chris_K
    Member
    Posted 9 years ago #

    yeah, go ahead and create an empty one and make sure that it is readable/writable by the httpd process owner.

    If you have console access, you could just navigate to the blog directory and do a "touch .htaccess". If you do it all via some ftp tool, maybe create a blank doc on your machine with that name and ftp it on up.

  8. Anne-Marie
    Member
    Posted 9 years ago #

    okay..sorry about the last reply, I looked in the wrong place, apparently I do have .htacces (looked via ftp, and then it didn't show up) and also under options -> permalinks it now says I need to update my .htacces. (went to direct-admin and there it is staring in my face)

    Now I am an idiot when it comes to new stuff and this all is new for me (the .htacces subject) so bare with me pls :)

    In this case I believe I donot need to make a new one. According to WP :If my .htacces was writable WP would have done it for me automatically, in this case I think I need to chmod my .htacces to a certain permission..now it is set to 644 do I need to change this to 755 or 777?

    When this is done what do I need to do next?

    Again I apologize...I'm really an idiot when it comes to new stuff, do appriciate the help that is given.

  9. Chris_K
    Member
    Posted 9 years ago #

    well, you could do a "chmod a+w .htaccess" or a "chmod 666 .htacess" I reckon. As far as I know, it doesn't need to be executable. But I'm no expert on this topic :-)

    Your ftp tool probably doesn't show hidden files by default (those that start with "." are considered hidden) which is why you didn't see it there.

    Once you get it to where it is readable and writable by "not you", then revisit the permalinks page and set your permalinks again.

  10. Anne-Marie
    Member
    Posted 9 years ago #

    Okay I've set it to 666 and according to WP the .htacces is updated. When I go to the url I still have the same problem. As you can see here : http://www.seacloudies.com/gallery/index.php?list=2 (differant url, cause first pasted url doesn't have an .htacces, but all is still the same)

  11. Chris_K
    Member
    Posted 9 years ago #

    Oh. I just realized I've been trying to help a wordpress blog issue, but the issue is with your gallery. Doh.

    I'm glad we got your WP permalinks sorted, but I don't know how much that'll impact the gallery software. I'll duck out in hopes that someone with that experience stops by.

  12. Anne-Marie
    Member
    Posted 9 years ago #

    Thnx HandySolo...just a bit weird that it works on one site and it doesn't work on the other. Although my site is an exact clone of the working one, just installed it again, integrated it again, step by step as Chris Payne set up his gallery, yet mine refuses to work correctly. Very strange...

  13. Anne-Marie
    Member
    Posted 9 years ago #

    Okay...don't want to start another topic just yet, anybody else have an idea what might be the problem?

Topic Closed

This topic has been closed to new replies.

About this Topic