Support » Fixing WordPress » index.php references gone

  • This is a fresh install of 1.5, fresh database, unknown if is a windows or linux host (leaning towards windows), fresh mysql database, no install problems.

    My issue is twofold:

    1. index.php will not load as the default for the directory i installed wordpress in. I get a page cannot be found error. There is nothing but the wordpress files in the directory.

    2. References that should contain index.php in the URL to not. Instead a link like “blah/index.php?cat=1” becomes “blah/?cat=1”.

    Whats wrong? Is this a WordPress issue or a server issue? I can use the admin control panel without problems. Changing skins does not help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Me too, i have the same problem and i really can’t get any solution. Is there really someone who has an idea about it? Is it because of a .htaccess problem or something else?

    For those having this problem, try this fix:

    http://wordpress.org/support/topic.php?id=26632#post-149803

    And let us know if it helps.

    It works for problem 2. Problem 1 remains.

    Make sure you have an entry in your .htaccess file that says:

    DirectoryIndex index.php

    1. index.php will not load as the default for the directory i installed wordpress in. I get a page cannot be found error. There is nothing but the wordpress files in the directory.

    The above problem i had two days ago. Its a .htaccess problem. You need to open your file viewer in your control panel for your hosting account, if you have that, and look for the .htaccess file in your wordpress main directory. Open it up in a file editor or just delete it if you dont plan on using it. Once you change that your index page should start working again. This took care of my problem.

    Open it up in a file editor or just delete it if you dont plan on using it.

    WordPress uses .htaccess rewrites to make a lot of things happen, so deleting it is generally not the best solution. Use the DirectoryIndex directive to tell Apache which file to look for in the absence of a specific file request in the URL.

    Hmmmm i wasnt aware that wordpress used .htaccess to do things. Mine didnt come with a .htaccess file to upload when i first installed it. I was adding a hack to my WP when i accidently uploaded the .htaccess for the hack into the main directory making it look for that scripts main page therefore not loading my index page giving me a DNS error……

    Mine didnt come with a .htaccess file to upload when i first installed it.

    WordPress will contruct it on-the-fly as needed.

    I was adding a hack to my WP when i accidently uploaded the .htaccess for the hack into the main directory making it look for that scripts main page therefore not loading my index page giving me a DNS error

    Yeah, borking an .htaccess file is the quick way to kill a site for certain.

    Setting index.php to the default DirectoryIndex leads to an IISPassword, page cannot be displayed error when accessing just the directory or index.php by itself.

    IISPassword
    The page cannot be displayed

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘index.php references gone’ is closed to new replies.