WordPress.org

Forums

index.php is not default document - htaccess disabled (4 posts)

  1. asdasdasd
    Member
    Posted 10 years ago #

    Hi, my webhost only set index.html as the default document, i.e. I can access my blog at example.com/wp/index.php , but all links will still point to example.com/wp/?p=1 but I need it to be example.com/wp/index.php?p=1

    .htaccess is disabled, so I cannot set it myself.

    Where do I have to tweak to include "index.php" in all the links generated by wp?

  2. moshu
    Member
    Posted 10 years ago #

    To make index.php a valid index file should be a piece of cake for the host. If they are not willig to do it - time to look for a real, normal host. I wouldn't stay one more minute with them!

    As for the index.php to be included in the links, you'll have to do it in your permalink settings.

  3. asdasdasd
    Member
    Posted 10 years ago #

    Sorry, can't change the host - and they're really hard to reach. So there should be some way of changing something in the functions that generate the links.

    Where should I dig?

  4. asdasdasd
    Member
    Posted 10 years ago #

    OK, so I found this buried inside the link-functions php file.

    I think it's kinda silly to hardcode things like '/?' - without a variable base file name

Topic Closed

This topic has been closed to new replies.

About this Topic