Support » Plugin: Yoast SEO » Indexing Problem

  • Resolved ellalener

    (@ellalener)


    Hello. Two week ago everything was worked perfectly. Every url submitted via webmaster was indexed almost instantly. Now when I submit new urls they are not shown in the google index when I check site: keyword etc. Strange part is that Google Webmaster show that the url is indexed but it is not. And all of a sudden 28 of 30 previously indexed posts disappeared. The homepage is still indexed. It is not penalty for sure and not cause of the last Google update. This website is new so I think that Yoast caused this problem. I pressed the Speed button from my wp dashboard so lets see what will happen. Let me know what can I do. The website is 100% legit with more than 40 categories and 20 pages already indexed. About the posts now only 2 posts out of of 31 are indexed.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Suwash Kunwar

    (@suascat_wp)

    Hi @ellalener,

    Sorry to know that you’re having indexing issues in Google search lately. Could you please provide us some example URLs for a test that you found are affecting from indexing or disappeared?

    Thread Starter ellalener

    (@ellalener)

    Can I send you the url somehow. I don’t like to post my website here. Please let me know.

    Plugin Support marcanor

    (@marcanor)

    Hi @ellalener ,

    Unfortunately, there’s no way to message us privately in this support forum.

    Please check the following details on your site:
    – Check the URLs that are not appearing in Google searches by doing a “site:URL” search. -Replace “URL” with the URL you want to check. The URL should appear in the search.
    – Check your indexing settings in SEO > Search Appearance > Content Types, Taxonomies. Make sure that the content types you want to have indexed are set to be shown in the search results.
    -Check the source code of your pages and do a search (CTRL+F or the equivalent on your operating system) for “noindex”.

    Can you please let us know what you find?

    Thread Starter ellalener

    (@ellalener)

    When I search site:posturl I got the default message “your search – site:posturl – did not match any documents:”.

    The settings from the Yoast dashboard for the posts are set yes (indexing allowed). It is also marked yes for the categories and pages except for the tag pages.

    Posts: https://prnt.sc/sieh7m
    Pages: https://prnt.sc/siehis
    Categories: https://prnt.sc/siehte

    And it is set to index in the source url too. Below is the code.

    <meta name=”robots” content=”index, follow” />
    <meta name=”googlebot” content=”index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1″ />
    <meta name=”bingbot” content=”index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1″ />

    Plugin Support devnihil

    (@devnihil)

    @ellalener We apologize for the confusion. When we said to do a search for ‘site:URL‘ we meant you should enter ‘site:‘ followed by the full URL to the page/post you are trying to check whether it is indexed. That URL should include your site’s domain, since you are instructing Google when using the ‘site:‘ operator to search within a specific site.

    Can you please try checking that and let us know whether the pages/posts in question are appearing in the search results?

    Thread Starter ellalener

    (@ellalener)

    I preformed search like site:myfullposturl.com and got the default message without any results. When I perform a search site:mydomain.com I see my homepage, two category pages and one post from my website shown in the results.

    Plugin Support devnihil

    (@devnihil)

    @ellalener If you have confirmed that the pages that are not being indexed do not contain a noindex tag, we would also recommend checking the following to ensure that Google isn’t being instructed to not index the pages:

    • Checking to make sure the robots meta tag is NOT set to ‘noindex’ for the individual page/post/category in Yoast SEO, which can override the global setting. You can check this setting by performing the following actions:

      Go to the Edit screen for a page/post
      Scroll down to the Yoast Metabox
      Click on the ‘Advanced’ area
      For ‘Allow search engines to show this Page in search results?’ make sure this is set to ‘Yes’
      Note (setting this value to Yes will set meta robots to ‘index’ and setting No would set meta robots to ‘noindex)

    • Check the global indexing of the site in WordPress, you can check this in the following way:

      In WordPress go to Settings>Reading
      Make sure for ‘Search Engine Visibility’ that ‘Discourage search engines from indexing this site’ is NOT checked
      Click ‘Save Changes’

    • Review your site’s robots.txt file to ensure that there are no directives in it that would prevent Google from crawling/indexing the site.

    • Make sure that the pages that are not being indexed do not contain an X-Robots tag in their header that is setting them to ‘noindex’. We have more information on this here: https://yoast.com/x-robots-tag-play/

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Closing due to inactivity.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Indexing Problem’ is closed to new replies.