WordPress.org

Forums

Fantastic ElasticSearch
[resolved] Indexing on post_date breaks search (7 posts)

  1. Marko Heijnen
    Member
    Posted 1 year ago #

    I'm not sure yet why but when I also enable indexing on post_date the search breaks. Not sure why the behaviour would change from WordPress when I just do site.com/?s=Hello. I wouldn't expect that post_date ends up in $args['query']['bool']['should']

    http://wordpress.org/plugins/fantastic-elasticsearch/

  2. Paris Holley
    Member
    Plugin Author

    Posted 1 year ago #

    probably shouldn't, created issue. will address in 2.0.0

    https://github.com/parisholley/wordpress-fantastic-elasticsearch/issues/25

  3. Paris Holley
    Member
    Plugin Author

    Posted 1 year ago #

    workin on putting this in now, just an FYI you can work around it by not setting post_date > 0 on the result scoring tab in admin

  4. Marko Heijnen
    Member
    Posted 1 year ago #

    Awesome and already did that. Still need to dig in the whole search logic. Is a bit weird but I saw you did change some stuff for the 2.0 version

  5. Marko Heijnen
    Member
    Posted 1 year ago #

    Can you add me on skype (markoheijnen). I would love to help out to make this plugin better. And improve it with widgets people can use.

  6. Paris Holley
    Member
    Plugin Author

    Posted 1 year ago #

    Sure thing, at an ufc event but will give you add tonight

  7. Marko Heijnen
    Member
    Posted 1 year ago #

    Okay cool. I'm at WordCamp San Francisco and had some talks with Automattic about elasticsearch.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Fantastic ElasticSearch
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.