Support » Plugin: The SEO Framework » Indexing Medias

  • Resolved tobias992

    (@tobias992)


    Hello,

    first sorry for my bad english, i am from germany. I hope you can understand my problem.

    In Settings i disabled indexing the Type Media. For me that means… no e.g. images will be crawled by Googlebot.

    I dont know how do you add the noindex flag to media files but for me thats not working. A good alternate solution for me is to set – add_header X-Robots-Tag “noindex”; – in my nginx config for media files… that helps.

    But the setting in your Plugin dont work for me.

    Or maybe i missunderstand these setting…

Viewing 1 replies (of 1 total)
  • Plugin Author Sybre Waaijer

    (@cybr)

    Hi Tobias,

    The settings prevent WordPress-generated media pages from being indexed. These pages almost never offer any value to users, and this is why the option enabled by default.

    To see such a page, go to your WordPress media library, select any image, and then you can see a link to the image page.
    In German: “WordPress Admin -> Medien -> Medienübersicht -> wählen ein Bild -> Anhang-Seite anschauen”

    Unfortunately, the plugin can’t easily touch media files served from your server. This is because those files aren’t presented by WordPress, but by Apache or NGINX. To remove those from the index (but, why would you?), please see:
    https://support.google.com/webmasters/answer/35308?hl=de

    Alternatively, if you want to provide the X-Robots-Tag header to images, please contact your hosting provider for further instruction. But, I see you’ve already gotten this far 🙂

    I hope this clears things up. Have a great weekend!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.