Support » Plugin: WordPress Sphinx Search Plugin » Indexing fails – Access denied by MySQL

  • When I run indexing I get the following error for each index:

    ERROR: index 'dev_main': sql_connect: Access denied for user 'caselaw'@'localhost' (using password: YES) (DSN=mysql://caselaw:***@localhost:3306/caselaw_dev).

    I have checked that the db credentials are correct, and I can connect to the db with the command line “mysql” utility with the same credentials.

    I am running PHP 7.

    I would really appreciate any suggestions.

Viewing 2 replies - 1 through 2 (of 2 total)
  • OK, so I edited the sphinx.conf file to log in to the db as root, and that got around the issue.

    I now get an error message as follows:

    FATAL: failed to open /home/root/domains/ No such file or directory, will not index. Try --rotate option.

    The ‘–rotate’ option is being invoked already – I am using the command generated by the wizard.

    That was dumb – I see the problem. I was a bit too enthusiastic changing the user to “root”.

    So it is indexing now, but only as “root”.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Indexing fails – Access denied by MySQL’ is closed to new replies.